W114 Power Steering Issue - Page 2 - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #11 of 14 (permalink) Old 05-09-2015, 05:16 PM
BenzWorld Veteran
 
Date registered: Jan 2007
Posts: 750
Mentioned: 2 Post(s)
Quoted: 82 Post(s)
Yes. Just make sure that the fluid is a the line marked on the side of the reservoir. Turn the wheel slowly at first to make sure it's not going to overflow.

Chuck Taylor
Falls Church VA
1998 SL500
1959 220S
1970 280SL
ctaylor738 is offline  
Sponsored Links
Advertisement
 
post #12 of 14 (permalink) Old 05-10-2015, 08:24 AM
Premium Member
 
Date registered: Nov 2012
Posts: 1,241
Mentioned: 0 Post(s)
Quoted: 59 Post(s)
Premium Member
would like to see a picture of the sterring box top .
agillot is offline  
post #13 of 14 (permalink) Old 05-13-2015, 03:08 PM Thread Starter
BenzWorld Member
 
Date registered: Apr 2013
Vehicle: '95 E320 Wagon,'71 250C(For Sale!)
Location: SF Bay Area, USA
Posts: 247
Mentioned: 0 Post(s)
Quoted: 24 Post(s)
(Thread Starter)
Sorry for the delay in updates,

Here is the pic of the top of the steering unit:



I have not yet lifted the front end to test the reservoir levels. It looks pretty full as is. I will order a new filter and s.pump seal kit(they are cheap: <$5!).
hages is offline  
post #14 of 14 (permalink) Old 05-15-2015, 11:45 AM Thread Starter
BenzWorld Member
 
Date registered: Apr 2013
Vehicle: '95 E320 Wagon,'71 250C(For Sale!)
Location: SF Bay Area, USA
Posts: 247
Mentioned: 0 Post(s)
Quoted: 24 Post(s)
(Thread Starter)
When I lifted the front end with wheels off the ground, the reservoir was nearly empty vs full when on the ground. Refilled it and confirmed the level was going to be consistently full from turn lock to turn lock. I have not driven the car to confirm the PS is back to normal but will assume so.

Other interesting thing, that I found what appears to be the filter element: a ceramic -like ring. Is that original?

Yup, low fluid was all it was. Weird I had to lift the wheels up to get true reservoir level.

Thanks all!

Last edited by hages; 05-15-2015 at 04:17 PM.
hages is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome