W123 240D A/C A/C Condensation Evacuation Tube Not Working - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-01-2015, 05:04 AM Thread Starter
BenzWorld Member
Date registered: Dec 2008
Posts: 130
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
(Thread Starter)
Question W123 240D A/C A/C Condensation Evacuation Tube Not Working

Have a 1982 240D Sedan w/Manual Transmission and full A/C unit that is working properly except for one item. Have noticed that there is no pooling of water underneath this car when engine is turned off and it is parked. There appears to be NO release of condensation from A/C unit through the tube intended for this purpose. Have fully cleared this tube of years of build up from hardened algae et al yet it still is not releasing any condensation from A/C usage.

Have had a lingering leakage problem with water coming into passenger cabin from outside during heavy rain storms. Have fully replaced floor boards in car, replaced weather stripping/seals on doors to minimize water leakage. Yet it now appears that the condensation from A/C unit is slowly leaking back into cabin of car from a/c-heater box mounted behind middle console under the dash rather than through the tube intended for this purpose.

This car is not leaking any anti-freeze.

Is there some kind of sealed vacuum valve underneath the a/c-heater box or a torn/aging gasket around a bolt that might be causing this leakage?

Any thoughts on how to FIX this problem or has anyone experienced a similar phenomenon with their W123 sedan?
teddyd49 is offline  
Sponsored Links
post #2 of 2 (permalink) Old 05-01-2015, 07:41 AM
Premium Member
Date registered: Nov 2012
Posts: 1,241
Mentioned: 0 Post(s)
Quoted: 59 Post(s)
Premium Member
remove the under dash covers , and look at top of tunnel , you will see the drain there , i ll bet the hose is shot [ common ]]
agillot is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome