No heat in 280c 114 - ideas? - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 12-11-2014, 08:01 PM Thread Starter
BenzWorld Member
 
tombot's Avatar
 
Date registered: Sep 2013
Vehicle: 1963 230SL & 1972 280C (sold sadly) & 1973 280C
Location: Portland, OR
Posts: 70
Mentioned: 0 Post(s)
Quoted: 11 Post(s)
(Thread Starter)
No heat in 280c 114 - ideas?

Hi. A couple weeks ago the heater would roast you out. Now nothing. Since a week of freezing temperatures in Portland OR that is.


Today on the drive home I could swear I heard what sounded like about a quart of water swooshing forward whenever I braked. Related?

When I got home, I popped the hood and felt All 3 hoses going into the firewall. And all 3 were hot.

Passenger and driver levers/cables are moving correctly. The middle hose (I assume) is the return hose and it was hot.

I can't guarantee that "sound" of water swoosh was from the core actually I thought it was at my feet which makes no sense I realize.

At the same time if I was just leaking coolant I am sure j would have seen some on my driveway but no. Dry.

What could be going on ?

Tom


Sent from AutoGuide.com Free App
tombot is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 12-12-2014, 09:46 AM
Premium Member
 
Date registered: Nov 2012
Posts: 1,241
Mentioned: 0 Post(s)
Quoted: 59 Post(s)
Premium Member
i think you are just very low on coolant .
agillot is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome