Vacuum probs '85 300SD - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-15-2014, 01:54 PM Thread Starter
BenzWorld Newbie
 
Date registered: Oct 2014
Vehicle: 1985 300SD
Location: Louisville, CO
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Garage
(Thread Starter)
Vacuum probs '85 300SD

So, I blew my first 300sd engine trying to teach my ex how to do a valve adjustment. Finally got a new engine in, but it was my first swap, and I really did not pay enough attention to the vacuum system. That said, I have learned quite a bit. Anyways, I am having problems with power when the car is in gear. It revs super high in neutral, but I put it in gear, and almost doesn't accelerate. So I figured i'd start messing with the vacuum system. I am currently following the vacuum lines to the trunk on the passenger side. If you could tell me if I'm off or just totally wrong I would appreciate it immensely!! So, I found three lines, one to the fuel check system, one to the trunk lock, and the other to what I though was going to be a vacuum reservoir, but was instead another vacuum pump?? Is this in case you run out of vacuum when the engine if off? Should there be a one way valve inline somewhere, and should this pump hold vacuum if I test it? Also, is there a reservoir somewhere? I replaced the ALDA line as I heard that could cause some power problems, but it didn't do anything. -Thanks for any input you might have! Thanks a bunch,

-Andrew
dawtspot is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 10-15-2014, 05:41 PM
Premium Member
 
Date registered: Nov 2012
Posts: 1,241
Mentioned: 0 Post(s)
Quoted: 59 Post(s)
Premium Member
the 126 car does not use any vacuum from the engine to the power locks , so , dont go there .the pump in trunk does it all .the vacuum system has nothing to do with low power .also i have never replaced the aneroid at injection pump , it does not go bad .there is a line that goes from the aneroid to a valve at fire wall and then to rear of intake manifold , connect that line from aneroid directly to the back of intake bypassing the valve .make sure the fitting at intake manifold is clear [ r/r and clean .] make sure the turbo spins . dont use any vacuum line at the EGR valve , keep it closed .
agillot is offline  
post #3 of 3 (permalink) Old 11-05-2014, 02:31 PM Thread Starter
BenzWorld Newbie
 
Date registered: Oct 2014
Vehicle: 1985 300SD
Location: Louisville, CO
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Garage
(Thread Starter)
Ok, so I found out the vacuum pump in the trunk was not working, so I replaced it, and fixed a couple leaks, and now my door work! Yay. Still have shifting problems, so I checked out the bowden cable, which was not attached to the transmission, and was busted.. so I bought a used bowden cable, but it looks like the piece on the transmission where the end of the bowden cable is supposed to attach is broken. Imagine a metal up side down 'J' coming out of the transmission.. not sure how I should go about fixing this. I almost want to try tying a knot on it and taping it. lol. J/k! Any suggestions would be very helpful, even if you just have a pic of what the attachment on the transmission is supposed to look like. I'm hoping I'm just slow

-Andrew
dawtspot is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome