1978 230 Euro sputtering issue - Page 3 - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #21 of 21 (permalink) Old 11-21-2014, 09:54 AM Thread Starter
BenzWorld Junior Member
78Benz230's Avatar
Date registered: Oct 2014
Vehicle: 1978 230 Euro
Location: Caldwell, Idaho, USA, North America, Earth, Sol System, Milky Way Star Cluster
Posts: 25
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Send a message via Skype™ to 78Benz230
(Thread Starter)
Hey everyone, me again.

I ended up replacing the fuel pump with the Pierburg from EBay. The other one was dumping fuel and sucking air so bad that it couldn't wait any longer.

A new problem has arisen, though.

It seems with a steady, even fuel flow, free of air bubbles, my car is unable to cope and won't stay running.

It almost feels like the engine gradually loses power and then just stops. If you keep your foot on the gas, even if you just give it a tiny bit, it stays running.

I don't understand the Stromberg on it at all, either, so if anyone has a schematic of a Stromberg 175, please send it!

I appreciate you all putting up with me not knowing what's going on. The only car I've ever worked on other than this was a 1960 Oldsmobile with a 390 V8, so I'm learning a whole new language here.

P.s. still haven't had the timing checked.
78Benz230 is offline  
Sponsored Links
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome