When were the big black Bosch voltage regulators used with a generator ? - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 08-22-2014, 02:54 PM Thread Starter
BenzWorld Newbie
 
Date registered: Aug 2014
Vehicle: dreamimg of a barnfind 300SL
Location: USA
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
When were the big black Bosch voltage regulators used with a generator ?

Just wondering when MB stopped using the big black Bosch Voltage regulators ?

was it when they stopped using generators and changed to alternators ?

one book says 1964 and another 1967 so i am confused !

Thanks for stopping my confusion , at least a little
FiatJolly is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 08-22-2014, 03:05 PM
Outstanding Contributor
 
television's Avatar
 
Date registered: Sep 2005
Vehicle: 216 with everything. 2002 SL500 with everything. 2009 SL500 with everything.
Location: South coast .England
Posts: 6,543
Mentioned: 1 Post(s)
Quoted: 148 Post(s)
It was a gradual change and alternators slowly phased in, a new model in 64 may have one, where as an ongoing model may not till 67

Malcolm

"I thought my vasectomy would keep my wife from getting pregnant but apparently it just changes the color of the baby."
television is offline  
post #3 of 4 (permalink) Old 08-22-2014, 05:30 PM
BenzWorld Elite
 
LWB250's Avatar
 
Date registered: Jan 2013
Vehicle: 90 350SDL, 98 S420, 97 SL500, 94 S420, past owner of W108/W112/W114/W123/W124/W126/W140 & W220 cars
Location: Tampa, FL
Posts: 4,424
Mentioned: 8 Post(s)
Quoted: 635 Post(s)
They were used as late as 1970. I had both a 250C (W114) and a 280S (W108) 1970 models that had them.

Dan
LWB250 is online now  
post #4 of 4 (permalink) Old 08-25-2014, 04:32 PM Thread Starter
BenzWorld Newbie
 
Date registered: Aug 2014
Vehicle: dreamimg of a barnfind 300SL
Location: USA
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks....so the book was right.....and wrong

it was a moving target from 63 thru 70 or so......

the one I have is 30 amp, is that what most of them are ?

Cheers
FiatJolly is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome