Just Bought A W114 - Page 5 - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #41 of 139 (permalink) Old 04-24-2014, 12:02 PM
w108,107 Parts Hoarder
 
Fonzi's Avatar
 
Date registered: Jun 2010
Vehicle: 4Keep:450slc5.0cab 280sl5sp 280se4.5 500seAMG 2sell:500sl92 380se83 300se86 350sl4sp 75slc MorInSig
Location: Philadelphia Area
Posts: 18,748
Mentioned: 27 Post(s)
Quoted: 1620 Post(s)
Lifetime Premium Member
Garage
Quote:
Originally Posted by dgosh28 View Post
125-150 psi on all cylinders

Compression ratio is supposed to be 9:1 assuming its a North American 1971 250 and Automobile-catalog.com has their info correct.
Just Bought A W114-imageuploadedbyautoguide1398362242.780031.jpg

I read here that 125 is on the low side, and 155 sounds about right. http://www.benzworld.org/forums/vint...gine-info.html

I don't know how compression ratios, but if atmospheric pressure is 14.7 psi, then 132.3 would be 9 times. So I would assume 125-150 sounds pretty good.


Sent from AutoGuide.com App

.

My signature:
Click for list of my 32 MB since 2010. If, you want 70's-80's Mercedes tuner wheels, let me know.
Fonzi is offline  
Sponsored Links
Advertisement
 
post #42 of 139 (permalink) Old 04-24-2014, 01:55 PM Thread Starter
BenzWorld Elite
 
dgosh28's Avatar
 
Date registered: Oct 2011
Vehicle: '71 250, '78 450SLC 5.0, '78 450SL, '81 380SLC 5.6, '89 260E, '15 Kia Sorento
Location: Houston, TX
Posts: 5,169
Mentioned: 24 Post(s)
Quoted: 103 Post(s)
(Thread Starter)
Well, she starts on starting fluid. Not to figure out why my carbs aren't pumping fuel.
dgosh28 is offline  
post #43 of 139 (permalink) Old 04-24-2014, 02:16 PM Thread Starter
BenzWorld Elite
 
dgosh28's Avatar
 
Date registered: Oct 2011
Vehicle: '71 250, '78 450SLC 5.0, '78 450SL, '81 380SLC 5.6, '89 260E, '15 Kia Sorento
Location: Houston, TX
Posts: 5,169
Mentioned: 24 Post(s)
Quoted: 103 Post(s)
(Thread Starter)
With the linkage missing I can't get the car to idle, but at least it starts.
dgosh28 is offline  
post #44 of 139 (permalink) Old 04-24-2014, 02:47 PM
w108,107 Parts Hoarder
 
Fonzi's Avatar
 
Date registered: Jun 2010
Vehicle: 4Keep:450slc5.0cab 280sl5sp 280se4.5 500seAMG 2sell:500sl92 380se83 300se86 350sl4sp 75slc MorInSig
Location: Philadelphia Area
Posts: 18,748
Mentioned: 27 Post(s)
Quoted: 1620 Post(s)
Lifetime Premium Member
Garage
Quote:
Originally Posted by dgosh28 View Post
Well, she starts on starting fluid. Not to figure out why my carbs aren't pumping fuel.

Are you bypassing the mechanical fuel pump? (My car came with a brand new one in the trunk, but I don't think I need it.)


Sent from AutoGuide.com App

.

My signature:
Click for list of my 32 MB since 2010. If, you want 70's-80's Mercedes tuner wheels, let me know.
Fonzi is offline  
post #45 of 139 (permalink) Old 04-24-2014, 04:29 PM Thread Starter
BenzWorld Elite
 
dgosh28's Avatar
 
Date registered: Oct 2011
Vehicle: '71 250, '78 450SLC 5.0, '78 450SL, '81 380SLC 5.6, '89 260E, '15 Kia Sorento
Location: Houston, TX
Posts: 5,169
Mentioned: 24 Post(s)
Quoted: 103 Post(s)
(Thread Starter)
Quote:
Originally Posted by Fonzi View Post
Are you bypassing the mechanical fuel pump? (My car came with a brand new one in the trunk, but I don't think I need it.)


Sent from AutoGuide.com App
No, we hooked new fuel line to the inlet side of the fuel pump and the other end to a gas can. We were thinking that my fuel pump may be bad. If yours is for sale I am your buyer. Pictures of the carburetor linkage would be welcome also.
dgosh28 is offline  
post #46 of 139 (permalink) Old 04-24-2014, 08:03 PM Thread Starter
BenzWorld Elite
 
dgosh28's Avatar
 
Date registered: Oct 2011
Vehicle: '71 250, '78 450SLC 5.0, '78 450SL, '81 380SLC 5.6, '89 260E, '15 Kia Sorento
Location: Houston, TX
Posts: 5,169
Mentioned: 24 Post(s)
Quoted: 103 Post(s)
(Thread Starter)
If anyone has an extra Zenith dual carb linkage set up for sale please PM me with a price. Mine is completely missing.
dgosh28 is offline  
post #47 of 139 (permalink) Old 04-24-2014, 08:09 PM
BenzWorld Member
 
Date registered: Sep 2010
Vehicle: 1976 300SD, 1995 E300D
Location: South Dakota
Posts: 70
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
You maybe want to talk to the ladies. Maybe it is in his garage somewhere. I'm assuming you've looked high and low in the car.
SinSL likes this.

currently:
76 300D (British red)
95 E300D (metallic charcoal)
2_300_D is offline  
post #48 of 139 (permalink) Old 04-24-2014, 08:28 PM Thread Starter
BenzWorld Elite
 
dgosh28's Avatar
 
Date registered: Oct 2011
Vehicle: '71 250, '78 450SLC 5.0, '78 450SL, '81 380SLC 5.6, '89 260E, '15 Kia Sorento
Location: Houston, TX
Posts: 5,169
Mentioned: 24 Post(s)
Quoted: 103 Post(s)
(Thread Starter)
Quote:
Originally Posted by 2_300_D View Post
You maybe want to talk to the ladies. Maybe it is in his garage somewhere. I'm assuming you've looked high and low in the car.
I have thought about calling them for a couple different reasons. One is I really could use a new bill of sale, but I think that ship has already sailed. I doubt the seller knows where the parts are since she lives 2 1/2- 3 hours away, but I guess it wouldn't hurt to call. If I can find replacement linkage I will just buy it and be done with it. maybe I need to take a trip to the local salvage yards on Sunday and see if I get lucky. I could always order from the Classic Center I bet. Probably cost more than I paid for the car though.
dgosh28 is offline  
post #49 of 139 (permalink) Old 04-24-2014, 08:31 PM Thread Starter
BenzWorld Elite
 
dgosh28's Avatar
 
Date registered: Oct 2011
Vehicle: '71 250, '78 450SLC 5.0, '78 450SL, '81 380SLC 5.6, '89 260E, '15 Kia Sorento
Location: Houston, TX
Posts: 5,169
Mentioned: 24 Post(s)
Quoted: 103 Post(s)
(Thread Starter)
Quote:
Originally Posted by 2_300_D View Post
Good start!
I picked up my E300D this AM from a shop that put new brakes, rotors & wheel bearing in the front.
I didn't get a chance earlier to ask, but do you have pics of your cars?
dgosh28 is offline  
post #50 of 139 (permalink) Old 04-24-2014, 10:51 PM
Lifetime Premium Member
 
93SoCal400E's Avatar
 
Date registered: Jul 2008
Vehicle: 2005 CLK500 w/23K !
Location: Hollywood
Posts: 587
Mentioned: 0 Post(s)
Quoted: 24 Post(s)
Lifetime Premium Member
Quote:
Originally Posted by dgosh28 View Post
If anyone has an extra Zenith dual carb linkage set up for sale please PM me with a price. Mine is completely missing.
There are at least 3 sets of the carbs on Ebay.

Maybe get in touch with one of the sellers, see if they can help.

Cheapest set of the carb there is $79. There is a Weber setup, new for $840.

It looks like one of the fuel lines into carb was disconnected when you looked initially. The metal isn't shiny so it appears it was like that for awhile.

This one:

Mercedes Late W111 220S 230s Zenith Dual 2 Carburetors Zenith 35 40 Inat T1 | eBay

Has a lot of really good plix in high res with decent light.

If fuel line was left open it could be dirty. Don't know these specific carbs but that inlet point on Rochester carbs of the era had a small metal fuel filter right there at carb inlet. (RED circled items)

It certainly looks like PO was working on a fuel/carb issue.

It also looks like he didn't finish, or it would be back together.

And if it sat in a dusty field for 3 years with fuel lines open....

When fuel is in carb and the float reaches top, the accelerator pump should work. It is a little triangular tab that turns upward while throttle opens. If there is fuel in bowl, opening throttle should cause a spray of fuel, even with engine off. Usually only get 1 or 2 of these without fuel pump running. But that would show when gas is available in carbs.

So you should be able to move throttle open and see gas spray and smell it. (Accelerator pump on front carb is BLUE)

If carbs leak at all, they will need to be rebuilt for sure.

I see at least 2 vacumn lines not connected. The one on upper left in GREEN is some sort of idle advance, likely for cold start or AC operation. In these pix, it is connected with a red line, might help to do the same, if nothing else it will stop one vac leak.

It really looks like someone was in middle of repair and walked away. You will need to find good images of where all of the lines went. Some vacumn lines are such that if they aren't connected or plugged, the car won't idle for sure.
Attached Thumbnails
Click image for larger version

Name:	Screen-Shot-2014-04-24-at-9.56.02-PM.jpg
Views:	28
Size:	75.5 KB
ID:	909065   Click image for larger version

Name:	Screen-Shot-2014-04-24-at-9.56.55-PM.jpg
Views:	23
Size:	69.1 KB
ID:	909073   Click image for larger version

Name:	Screen-Shot-2014-04-24-at-9.55.38-PM.jpg
Views:	23
Size:	74.0 KB
ID:	909081   Click image for larger version

Name:	carb.jpg
Views:	22
Size:	103.6 KB
ID:	909097  

Last edited by 93SoCal400E; 04-24-2014 at 11:09 PM.
93SoCal400E is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome