new boy in old Merc land ! - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 30 (permalink) Old 01-10-2014, 05:37 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Jan 2014
Vehicle: 1963
Location: Spain
Posts: 13
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Talking new boy in old Merc land !

hello to all, Id like to get straight to it and make my introduction here if possible
im sig, a english furniture designer / architect working for the last 20 years near barcelona in spain. Ive been toying with classic cars since I was 18 and recently (ie, last autumn) I decided to give it a proper go!. the luxury furniture market is fragile to say the least so after the success of a recently restored 2cv. I decided to move up market a little bit.
noone in spain has any money so I ended up swapping my 1972 ford cortina for a 1963 (?) 220S. the deal was that the bloke got it up and running as it had been stood since 1991. so he did that and it arrived home yesterday. it has the 4 pot diesel engine in instead of the (as I understand ) original 6 cylinder petrol.
so in the cold light of day the car is more work than I thought. there are plenty of rust bubbles under the paint, but that doesnt bother me much as metal working is my thing!
amazingly all the electrics work straight off even brake lights and horn, the engine starts well and the interior is the velour beige one (which needs a good clean).
however it spews out water from the water pump andf has next to no power whatsoever??
heres the pix





I read on someone elses thread here that lack of power and speed is probably due to the filters ? Im guessing in this case its the diesel filter in the tank as when we drained it it even then came out quite slowly as if there was a blockage. Im hoping this will provide me with the missing power.

also the water pump leaks from the 2 holes on the outside of the pump. now Ive been wondering why those holes exist ! and if I threaded them and sealed them wouldnt that simply stop the leaking problem??...I am however guessing that maybe they exist for oiling the bearings or something and that if it leaks it means the seals are knackered and I need a new pump?...it would however be nice to do a quick botch while im waiting for a new one so I can get the other motor issues sorted..any ideas ??
Im sure you guys will be able to help loads as Im feeling a bit lost in benzworld.
cheers in advance sig


sigfurniture is offline  
Sponsored Links
Advertisement
 
post #2 of 30 (permalink) Old 01-10-2014, 06:50 AM
BenzWorld Elite
 
rumb's Avatar
 
Date registered: Oct 2012
Vehicle: 1968 250S, 1991 300se, 1998 SL500, 2x 1977 450SEL 6.9. Past MB's; 300SD, 300E, 300TE, 190E, ML420
Location: Colorado
Posts: 2,349
Mentioned: 5 Post(s)
Quoted: 425 Post(s)
Garage
Welcome, your car looks nice. hubcaps would be nice. I'm afraid you just need to replace your water pump.
rumb is offline  
post #3 of 30 (permalink) Old 01-10-2014, 09:02 AM
BenzWorld Extremist
 
50$84sd's Avatar
 
Date registered: Oct 2009
Vehicle: 1965 220se w111 *******1984 300sd w126 *******1991 350sd w126
Location: SO CAL USA
Posts: 911
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Welcome and nice looking 220S. Water pump leaking at the holes is just a way of saying it needs a new one.
The car being slow with the diesel in it may just be typical of those years or maybe if original trans and rear end are still there the ratios could be different (maybe).
I like the tails with the yellow corners, all the ones in US are just red. Good luck with it. Later.

50$84sd is offline  
post #4 of 30 (permalink) Old 01-10-2014, 11:07 AM
BenzWorld Elite
 
Date registered: Jul 2008
Posts: 4,807
Mentioned: 4 Post(s)
Quoted: 320 Post(s)
Sweet color combo!!! are those velour seats? nice!
cooljjay is offline  
post #5 of 30 (permalink) Old 01-10-2014, 12:06 PM
BenzWorld Elite
 
DirectLA's Avatar
 
Date registered: Jan 2007
Vehicle: 1962 W111 220SE Coupe
Location: Cloud City, OR
Posts: 2,289
Mentioned: 1 Post(s)
Quoted: 8 Post(s)
Fun car, congrats. Those are called "weep holes" and are there specifically to let you know when the pump is bad. It needs replaced.

-Marrs

The Coupe Group (W111/112 coupes and cabs)official website
The Coupe Group on Facebook


"Too many people are working at jobs they hate, to buy things they don't particularly want, to impress people they don't even care about." --Dr. Deepak Chopra
DirectLA is offline  
post #6 of 30 (permalink) Old 01-10-2014, 12:53 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Jan 2014
Vehicle: 1963
Location: Spain
Posts: 13
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by DirectLA View Post
Fun car, congrats. Those are called "weep holes" and are there specifically to let you know when the pump is bad. It needs replaced.
well it certainly was balling its eyes out thats for sure! new one ordered.
i tried draining the tank again this afternoon, and I saw the small fuel filter in there which does look a bit brown and cacked up, but how do I get it out??, Im assuming its something to do with the massive allen key plug in the bottom of the tank...any clues before I tear into it?, cheers for the welcome folks
sigfurniture is offline  
post #7 of 30 (permalink) Old 01-11-2014, 02:31 AM
BenzWorld Member
 
Date registered: Jan 2009
Vehicle: anywhere from '52 300 to 1990 560SEL,and a '93300TE nothing newer, too much trouble....
Location: N L A County
Posts: 361
Mentioned: 0 Post(s)
Quoted: 11 Post(s)
Filters

Quote:
Originally Posted by sigfurniture View Post
well it certainly was balling its eyes out thats for sure! new one ordered.
i tried draining the tank again this afternoon, and I saw the small fuel filter in there which does look a bit brown and cacked up, but how do I get it out??, Im assuming its something to do with the massive allen key plug in the bottom of the tank...any clues before I tear into it?, cheers for the welcome folks
Yes , that plug has a strainer to filter all fuel before it enters the bottom layer in that tank. If it gets clogged (years of debris and maybe a lot of rust it will slow the flow). There should be a couple more fine filters in the engine compartment.
The lack of power could be several issues.
Filters is the first step, then check compression, then maybe valve adjustment, IP timing...worn timing chain ...?

BTW :
you have the best of both worlds. The classy S-class body with the economical and indestructible 200D motor....should get 35 miles per gallon if it runs right (7 to 8 liters per 100km)

Good Luck

Alex

PS I have a cousin in Barcelona.
6punkt3 is offline  
post #8 of 30 (permalink) Old 01-13-2014, 07:29 PM
BenzWorld Elite
 
DirectLA's Avatar
 
Date registered: Jan 2007
Vehicle: 1962 W111 220SE Coupe
Location: Cloud City, OR
Posts: 2,289
Mentioned: 1 Post(s)
Quoted: 8 Post(s)
When you clean or replace the strainer go ahead and have the inside of the fuel tank cleaned out and resealed. Otherwise you will not prevent scale, rust and debris from accumulating again and clogging. It makes life much easier.

-Marrs

The Coupe Group (W111/112 coupes and cabs)official website
The Coupe Group on Facebook


"Too many people are working at jobs they hate, to buy things they don't particularly want, to impress people they don't even care about." --Dr. Deepak Chopra
DirectLA is offline  
post #9 of 30 (permalink) Old 01-14-2014, 05:11 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Jan 2014
Vehicle: 1963
Location: Spain
Posts: 13
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
great thanks for the tip offs, when I find a hexagonal tool so big Ill have a go at the tank, Ive started cutting out the rust and treating the inner doors etc.

also I found 5 winter tyres with 14 inch wheels and hub caps for 130 which are on there way. the tyres that are on it are trashed.

also there is a knackered w111 in a scrap yard nearby , I need to pass by and get some spares off it...which will be great fun
sigfurniture is offline  
post #10 of 30 (permalink) Old 01-20-2014, 12:18 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Jan 2014
Vehicle: 1963
Location: Spain
Posts: 13
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
pleased with todays efforts. the 14 inch wheels arrived and are on, the water pump is in and working well, and the scrap yard find was a bargain. I got the 2 front seats and the rear back part of the seat, aswell as a headlight and bevel and also the 2 front seats of a 2cv (another project) for 100€


sigfurniture is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome