Sooo, I bought myself a new toy, and it broke within two hours! - Page 2 - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #11 of 15 (permalink) Old 11-09-2013, 12:34 PM
BenzWorld Elite
 
redghost's Avatar
 
Date registered: Oct 2012
Vehicle: 1972 220 D, 1974 450SL, 1995 E300D 2002 S430, 1976 300D
Location: Seattle
Posts: 1,822
Mentioned: 0 Post(s)
Quoted: 241 Post(s)
I should be able to supply the emblems. There is not much beyond the rear emblem that is w115 240D specific.

By spotlight, do you mean the front fog? Round light between the grill and headlamp. I will need to inventory to see what all else I have. Front brake rotor for sure, window glass, some trim, and tail lamps

Clay

74 450SL - Froggy
'02 s320 - Victor
'76 300D - Voldemort
'95 E300D - Cleo
'72 220D - Gump
'87 300SDL - POS SDL

92 300SE - #1 boys ride
redghost is offline  
Sponsored Links
Advertisement
 
post #12 of 15 (permalink) Old 11-09-2013, 02:29 PM
BenzWorld Elite
 
Date registered: Dec 2012
Vehicle: 1984 300D turbo 1982 380SL 1981 380SL 1984 300SD
Location: 35 degrees North
Posts: 1,709
Mentioned: 1 Post(s)
Quoted: 678 Post(s)
Quote:
Originally Posted by enyt View Post
I am not sure that it is the same but my 1982 300d has the alternator and water pump on the same belt; that is why it needs to be repaired.
what caused the belt to break? I had my alternator seize once and that had to also be replaced.
heh heh.

My mistake.
benzbarz is offline  
post #13 of 15 (permalink) Old 11-09-2013, 07:05 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Oct 2013
Posts: 23
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Yeah, I need one fog lamp then, one is cracked, and also the trunk seal, and the rear passenger side door seal. I guess these items are of lesser importance to getting the car a bit more reliable though..

Today, I fitted then new glow plugs. Unfortunately, there was no difference in it's terrible cold starting (have to turn it over 3/4 times for a while before it eventually fires up.) Once it's warm it starts up straight away, runs smooth as silk, pulls cleanly, good oil pressure, water temperature solid as a rock etc.

One thing I did notice - the glow plug indicator light on the dash does not come on at all. Could my problem lie in the relay perhaps? Maybe the glow plugs aren't getting any power, and what (eventually) starts the car from cold is purely the heat produced by the repeated turning over?
BenA105 is offline  
post #14 of 15 (permalink) Old 11-10-2013, 10:01 PM
BenzWorld Member
 
Date registered: Mar 2011
Vehicle: 1971 250/8 sedan with 80 K miles. Driven only in Summer.
Location: Vancouver BC Canada
Posts: 107
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Hi Ben. I hope you have a dry place to store the car when the weather gets bad. There are a few weak spots on the body you should know about. #1 is the air intake or waterbox under your front windshield. #2 is the area around your front lights. Remove any dirt and inspect the fender coating. Remove the front mats and look for moisture. Also inspect the trunk and remove the matt. # 3 is the bottom of your doors .Hope everything is dry and no rust is showing. Good luck with your new toy. Harald
Over 75 is offline  
post #15 of 15 (permalink) Old 11-12-2013, 04:51 PM
BenzWorld Elite
 
redghost's Avatar
 
Date registered: Oct 2012
Vehicle: 1972 220 D, 1974 450SL, 1995 E300D 2002 S430, 1976 300D
Location: Seattle
Posts: 1,822
Mentioned: 0 Post(s)
Quoted: 241 Post(s)
Do not forget behind the wheel wells up front. That place likes to store muck. Easy to remove the panel and hose it out. Best to check all weep holes for function anyway. Window seals will cause cabin and trunk leakage/rust.

+1 on removing carpet/mat. Pull it all up and feel for dampness. The cabin mats are a sponge. If you do find rust, brush it to bare metal and then use POR-15 to protect. Topcoat with rubberized undercoating.

Clay

74 450SL - Froggy
'02 s320 - Victor
'76 300D - Voldemort
'95 E300D - Cleo
'72 220D - Gump
'87 300SDL - POS SDL

92 300SE - #1 boys ride
redghost is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome