300d died when making a corner - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 10-09-2013, 07:55 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Aug 2013
Vehicle: 1976 300d mercedes
Location: Southern California
Posts: 9
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
300d died when making a corner

this morning driving to work early, I was about 1 mile into my journey when i herd a pinging noise and when i made a right my car shut off. it wouldn't turn over but after the tow truck dropped it off at my house I waited a few hours then it tried to turn over but it was pretty slow.

could this be a blown engine? or clogged fuel lines?
grantnoble is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 10-10-2013, 08:51 AM
Premium Member
 
Date registered: Nov 2012
Posts: 1,241
Mentioned: 0 Post(s)
Quoted: 59 Post(s)
Premium Member
sound like a engine problem , the vacuum pump falls apart , and the pieces end up in the timing chain .that or you dropped a prechamber , or ran out of oil .
agillot is offline  
post #3 of 5 (permalink) Old 10-10-2013, 09:09 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Aug 2013
Vehicle: 1976 300d mercedes
Location: Southern California
Posts: 9
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
I just checked the oil on my dipstick, theres literally nothing on it...........im putting a new fuel primary and secondary pump as we speak....and if i put oil in do you think she will be good?
grantnoble is offline  
post #4 of 5 (permalink) Old 10-10-2013, 01:53 PM
BenzWorld Elite
 
Date registered: Jul 2008
Posts: 4,807
Mentioned: 4 Post(s)
Quoted: 320 Post(s)
Probably not......where did all the oil go?

Have you not checked it?

Blown oil cooler line?

Head gasket?

Oil had to go somewhere....
cooljjay is offline  
post #5 of 5 (permalink) Old 10-11-2013, 01:48 AM
BenzWorld Member
 
Jackpody's Avatar
 
Date registered: Oct 2012
Vehicle: Mercedes Benz W108 - 280 SE (1970) / Mercedes-Benz W123 200T (1983)
Location: Denmark
Posts: 224
Mentioned: 0 Post(s)
Quoted: 12 Post(s)
Possibly seized running with no oil. Did it smoke like in hell, by any chance? How was the oil pressure before seizing? I've been able to leave oil puddles around and still not loose any noticeable oil on the dipstick, so if it all disappeared, you'd be able to see it.
Jackpody is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome