1976 300D transmission issue - Page 2 - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #11 of 12 (permalink) Old 08-05-2013, 08:27 AM Thread Starter
BenzWorld Member
 
Date registered: Sep 2010
Vehicle: 1976 300SD, 1995 E300D
Location: South Dakota
Posts: 70
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
any idea's. This puzzles the heck out of me. it worked when I parked it. Could it be something to do with the vacuum? Vacuum seems to be everything on these old girls. I've got a vacuum tester.
gus

Quote:
Originally Posted by agillot View Post
if you have changed the fluid / filter 1000 miles / 4 years , that is not your problem .

currently:
76 300D (British red)
95 E300D (metallic charcoal)
2_300_D is offline  
Sponsored Links
Advertisement
 
post #12 of 12 (permalink) Old 08-05-2013, 10:29 AM
BenzWorld Elite
 
Govert70227's Avatar
 
Date registered: Oct 2009
Vehicle: 2000 VW Golf Variant
Location: Leiden, Netherlands
Posts: 2,952
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
The 1976 300D doesn't use vacuum for the transmission (unless the transmission has been changed).
Govert70227 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome