w114 engine help! - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 07-30-2013, 01:03 AM Thread Starter
BenzWorld Member
 
Date registered: Jan 2012
Vehicle: 1970 Mercedes 220D
Location: California
Posts: 61
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
(Thread Starter)
w114 engine help!

I am in need of a cam and cam bearings, (all four). I have a 1972 250c with a M130.923 engine, single cam. Can anyone help???
My 220D is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 07-30-2013, 03:08 PM
BenzWorld Extremist
 
kavadarci's Avatar
 
Date registered: Aug 2008
Vehicle: 1971 250C
Location: Toronto, Canada
Posts: 1,056
Mentioned: 0 Post(s)
Quoted: 14 Post(s)
hi,
my camshaft bearings are gone (at least that's what i have been told).
i am also looking to either rebuild or buy from here:
Mercedes Rebuit Engines
those guys sell balanced camshaft with all the bearings, don't just replace the camshaft, you need to do the rod bearings if you are there.

the bearings can also be purchased from here:

Your Parts Search Returned 3 Part(s)

in both cases for me i have to pay shipping and customs to get them to canada.
if you are in the US it's better.

By the way, what is the problem with your engine?
maybe we have the same engine problem.
kavadarci is offline  
post #3 of 13 (permalink) Old 07-30-2013, 04:35 PM Thread Starter
BenzWorld Member
 
Date registered: Jan 2012
Vehicle: 1970 Mercedes 220D
Location: California
Posts: 61
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
(Thread Starter)
Camshaft

Hi,

I called the place on the link you sent. They can provide one for about $360 bucks which is better than what the dealer wants. New...cost over $700 bucks! Yuck.

Thanks again for the link, it turns out the shop is literally down the street from me so I will go see them and go from there.
My 220D is offline  
post #4 of 13 (permalink) Old 07-30-2013, 04:46 PM Thread Starter
BenzWorld Member
 
Date registered: Jan 2012
Vehicle: 1970 Mercedes 220D
Location: California
Posts: 61
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
(Thread Starter)
w114 engine

The problem I have is I heard a mean knocking coming from engine. Im suspecting that the piston is bad but when we took off the valve cover, we noticed that one of the cam bearings is cracked on top and one is worn, both giving a lot of play to the cam. The cam itself is grooved deep in the place where the last two cam bearings...(if you are facing the engine) sit and I believe that the knocking sound might have been the cam hitting the bearing tower and causing the noise....at least i'm hoping it is that. Also, the springs holding the rockers were all installed incorrectly.

I just bought this coupe from a guy that stated it had a head job done. Looking at the head, it looks like work was done to it but everything was installed incorrectly and left a few screws loose. So we will see if any damage occurred below the head!
My 220D is offline  
post #5 of 13 (permalink) Old 07-30-2013, 09:21 PM
BenzWorld Extremist
 
kavadarci's Avatar
 
Date registered: Aug 2008
Vehicle: 1971 250C
Location: Toronto, Canada
Posts: 1,056
Mentioned: 0 Post(s)
Quoted: 14 Post(s)
ok, so it is the camshaft, i was thinking it is the crankshaft.
is yours 2.8L m130 engine?
i would love to hear the sound of your engine,

here is video of my engine ticking when hot, specially pronounced when the idle goes down.

kavadarci is offline  
post #6 of 13 (permalink) Old 07-30-2013, 10:09 PM Thread Starter
BenzWorld Member
 
Date registered: Jan 2012
Vehicle: 1970 Mercedes 220D
Location: California
Posts: 61
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
(Thread Starter)
noises

I have my cam out of the engine. I do have a cracked cam bearing, the last one closest to the firewall. My noise came from that location. I will try to post pictures of my parts and the wear spots on the cam. My noise sounded more like something hitting...like metal on metal...

your engine ticks more, I think it may be the main bearings on the crankshaft. But, pull your cover and check the cam, cam bearings and rockers.

Have you have your valves adjusted? I have an old W108 with a 280SE engine and that guy ticked like crazy until I have the valves adjusted.

Some things to consider before tearing into the block.

I like the color on the cover!
My 220D is offline  
post #7 of 13 (permalink) Old 07-31-2013, 06:45 AM
BenzWorld Extremist
 
kavadarci's Avatar
 
Date registered: Aug 2008
Vehicle: 1971 250C
Location: Toronto, Canada
Posts: 1,056
Mentioned: 0 Post(s)
Quoted: 14 Post(s)
Hi,
i had the valves adjusted.
please post pictures of the wear as i did look but couldn't see.
maybe i just don't know what to look for.

if i take something apart i would rather deal with the top of the engine than taking the engine out.

Thank you and looking forward to the pictures.
kavadarci is offline  
post #8 of 13 (permalink) Old 08-03-2013, 12:45 PM Thread Starter
BenzWorld Member
 
Date registered: Jan 2012
Vehicle: 1970 Mercedes 220D
Location: California
Posts: 61
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
(Thread Starter)
cam issues

Hi,
Can't seem for the life of me post pictures! lol. Do you have an email that i can send you pics directly? I can show you how my bearings are shot and one is cracked open on the top.
My 220D is offline  
post #9 of 13 (permalink) Old 08-03-2013, 12:58 PM
BenzWorld Extremist
 
kavadarci's Avatar
 
Date registered: Aug 2008
Vehicle: 1971 250C
Location: Toronto, Canada
Posts: 1,056
Mentioned: 0 Post(s)
Quoted: 14 Post(s)
Pm sent
Check your inbox

Sent from AutoGuide.com Free App

Last edited by kavadarci; 08-03-2013 at 01:01 PM.
kavadarci is offline  
post #10 of 13 (permalink) Old 08-07-2013, 01:56 PM Thread Starter
BenzWorld Member
 
Date registered: Jan 2012
Vehicle: 1970 Mercedes 220D
Location: California
Posts: 61
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
(Thread Starter)
knocking sound continues

Ok, installed new cam and rockers and knocking is still there. My mechanic thinks it could be a valve not sitting correctly, so he will check to see if one is bent or if there is anything else knocking. Try checking your valves to see is that could be the culprit before tearing down engine.
My 220D is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome