1970 w114 250 Benz - Page 5 - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #41 of 70 (permalink) Old 06-06-2013, 08:18 PM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2013
Vehicle: 1970 250. W114. Sedan. Green
Location: Bethlehem PA
Posts: 36
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks Harald yep
That's my (equipment) shop, got a "pit" to...

Finally got her running tonight , spit sputtered carried on for 45 minutes, until I made up my mind to sit in seat and hold it at 1/4 throttle for 10 minutes then she evened out but still would die out at idle ( I then changed in line fuel filter)and it ran steady...

CRAZY thing happened as I was toying with the double zeniths,using carb spray and w40 my darn shop rag caught front fan and stopped fan .i quickly shut her down ,but now I have no fan function , i checked fuses they were ok thought I popped a fuse but now I have no frt. fan function. I wonder if I burnt it out?? Or is there a separate fuse for this.?
Is it normal for this fan to run as soon as ignition is on ,as it did.
Scared the heck out of me + one must be very aware of that open fan running while hood is open
Got one rear brake functioning also cant get fluid to bleed from other side

Can't find forums on the carbs as w114's are not listed in choices?
I will look into title info given from jaymayard

One other note as I fired it up tonight she stuck in full throttle momentarily till I nailed it down then found carb linkage came off and small retinue spring fell off
This is like climbing a mountain
Anthonycars is offline  
Sponsored Links
Advertisement
 
post #42 of 70 (permalink) Old 06-06-2013, 08:23 PM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2013
Vehicle: 1970 250. W114. Sedan. Green
Location: Bethlehem PA
Posts: 36
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
How bout the vin search as I entered my vin and no match comes up
Anthonycars is offline  
post #43 of 70 (permalink) Old 06-11-2013, 08:39 PM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2013
Vehicle: 1970 250. W114. Sedan. Green
Location: Bethlehem PA
Posts: 36
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Rumb
When you replaced the rear caliper(s) did you have to change the brake line connection into the caliper ,as I do not see a direct fit up , as mine seem to be origional
Anthonycars is offline  
post #44 of 70 (permalink) Old 06-12-2013, 06:47 AM
BenzWorld Elite
 
rumb's Avatar
 
Date registered: Oct 2012
Vehicle: 1968 250S, 1991 300se, 1998 SL500, 1977 450SEL 6.9. Past MB's; 300SD, 300E, 300TE, 190E, ML420
Location: Colorado
Posts: 2,362
Mentioned: 6 Post(s)
Quoted: 427 Post(s)
Garage
Are you saying the new brake line to the caliper has different size threads? If you had one made, they should be able to make it with the correct size.
Attached Thumbnails
Click image for larger version

Name:	250 rear brakes.gif
Views:	344
Size:	61.4 KB
ID:	520979  
rumb is online now  
post #45 of 70 (permalink) Old 06-12-2013, 04:18 PM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2013
Vehicle: 1970 250. W114. Sedan. Green
Location: Bethlehem PA
Posts: 36
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thank You for the diagram
my new original replacement caliper has a different location for the existing metal feed line [116 per diagram ] inlet { WOW this must be orig. caliper}ATI brand
After looking at diagram I believe I will need to make/buy a short jumper line which would go from old brake line to new caliper - Yea ? as I have new caliper installed
[ Almost ready to test drive -another day - I think }
Chow
Anthonycars is offline  
post #46 of 70 (permalink) Old 06-12-2013, 08:34 PM
BenzWorld Member
 
Date registered: Mar 2011
Vehicle: 1971 250/8 sedan with 80 K miles. Driven only in Summer.
Location: Vancouver BC Canada
Posts: 107
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
coming back to your carbs Anthony, there is a lot of info. under online resources
http://www.benzworld.org/forums/vint...sources-3.html on page 3 by Grubeguy. including your brake problems ect. Good luck. Harald
Over 75 is offline  
post #47 of 70 (permalink) Old 06-13-2013, 04:25 AM
BenzWorld Member
 
kdjones99's Avatar
 
Date registered: Jul 2010
Vehicle: 1967 250SE (W108)
Location: Michigan
Posts: 106
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
I had the same problem with the calipers. They make 2 different versions of calipers (for my 67 at least). I kept getting the one with the connection in the wrong spot too. Finally just took my originals in to get rebuilt.
kdjones99 is offline  
post #48 of 70 (permalink) Old 06-13-2013, 08:03 PM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2013
Vehicle: 1970 250. W114. Sedan. Green
Location: Bethlehem PA
Posts: 36
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thank Harald, kdjones99
Today I went to NAPA , they ordered rubber jump brake lines for me ,as orig. cal. Are out of production. Gotta wait 3 days now
Anthonycars is offline  
post #49 of 70 (permalink) Old 06-13-2013, 08:15 PM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2013
Vehicle: 1970 250. W114. Sedan. Green
Location: Bethlehem PA
Posts: 36
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Dropped rear diff oil tonight, actually looked golden new, not bad for last service was 12 years ago. Title is still problem , as I must surrender title to get my name on new title, in order to get insurance ,inspection plate etc even if I apply for a lost title
Anthonycars is offline  
post #50 of 70 (permalink) Old 06-13-2013, 08:25 PM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2013
Vehicle: 1970 250. W114. Sedan. Green
Location: Bethlehem PA
Posts: 36
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Jaymayard
If I retitle my benz I have to send in the orig.A title to PADOT , then they keep it
I can't apply for a lost title, as I never had the benz registered, yet.
I can,t even get plates with out surrendering orig. A title signed by the actress.
Unless I keep the car as is , and store it away , Don't want to d this,
Does this make sense
Anthonycars is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome