Ml320 running rough help me please - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-09-2013, 03:35 PM Thread Starter
BenzWorld Junior Member
Date registered: Jun 2012
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Ml320 running rough help me please

I have a 2002 ml320 that is running very rough. When I am driving and come to a stop the car will bog down and normally recover. Sometimes the car will stall and die as well. This does not happen all of the time. I took it to a parts store and got it scanned the came up with the codes P0172, P0175, and P0104. Last year around this time I have two of the spark plug wires replaced and that seemed to help for a while. Does anyone have any ideas?
jmulli13 is offline  
Sponsored Links
post #2 of 2 (permalink) Old 05-10-2013, 07:20 AM
BenzWorld Elite
rumb's Avatar
Date registered: Oct 2012
Vehicle: 1968 250S, 1991 300se, 1998 SL500, 2x 1977 450SEL 6.9. Past MB's; 300SD, 300E, 300TE, 190E, ML420
Location: Colorado
Posts: 2,257
Mentioned: 5 Post(s)
Quoted: 407 Post(s)
Head on over to the W163 forum, they will have your answers.
rumb is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome