'67 W108 Lower A-Arm FAilure - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 04-25-2013, 12:29 PM Thread Starter
BenzWorld Member
 
Date registered: Jul 2012
Vehicle: 1967 250S, twin Weber carbs, automatic trans, power windows, A/C, R134a conversion
Location: Texas
Posts: 107
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
'67 W108 Lower A-Arm FAilure

FYI

OMG! I just had the drivers side lower A-Arm break at the inner mount. I've seen a ball-joint failure before but nothing like this. The ams have less than 20k miles on them and included new pins. The only thing that kept the system on the subframe was the rear pivot and the sway-bar mount. The suspension was lubed frequently. Glad I did not crash into the adjacent car and was able to limp it home. Parts are on the way for repair and I hope to show a picture of the damaged part on this forum. I'm often under tha car doing something and saw nothing leading to this.
Kitaka is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 04-25-2013, 01:22 PM
BenzWorld Elite
 
DirectLA's Avatar
 
Date registered: Jan 2007
Vehicle: 1962 W111 220SE Coupe
Location: Cloud City, OR
Posts: 2,289
Mentioned: 1 Post(s)
Quoted: 8 Post(s)
Holy $hit! I'm glad you are ok and made it back safely, that must have been terrifying.
Did you use Mercedes-Benz or aftermarket when you replaced them?

-Marrs

The Coupe Group (W111/112 coupes and cabs)official website
The Coupe Group on Facebook


"Too many people are working at jobs they hate, to buy things they don't particularly want, to impress people they don't even care about." --Dr. Deepak Chopra
DirectLA is offline  
post #3 of 3 (permalink) Old 04-25-2013, 09:57 PM Thread Starter
BenzWorld Member
 
Date registered: Jul 2012
Vehicle: 1967 250S, twin Weber carbs, automatic trans, power windows, A/C, R134a conversion
Location: Texas
Posts: 107
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
I used MBZ parts. The arm tore away at the forward bore hole. No previous damage to prompt this failure
Kitaka is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome