W111 coupe 6.3 - Page 2 - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #11 of 26 (permalink) Old 11-29-2012, 03:47 PM Thread Starter
BenzWorld Member
 
Date registered: Sep 2011
Vehicle: 66 250se coupe w111, 65 600 swb limo, 89 560sl 90k original miles fully documented, 96 e320 280k mil
Location: Los Angeles CA
Posts: 209
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
w109 300sel 3.5

One of my fathers many full on restoration.

the rare 300sel 3.5

let me know what you guys think





pepelepew69 is offline  
Sponsored Links
Advertisement
 
post #12 of 26 (permalink) Old 11-29-2012, 03:54 PM Thread Starter
BenzWorld Member
 
Date registered: Sep 2011
Vehicle: 66 250se coupe w111, 65 600 swb limo, 89 560sl 90k original miles fully documented, 96 e320 280k mil
Location: Los Angeles CA
Posts: 209
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
w110 full Restoration

enjoy this nice w110 full restoration done by my father a couple years back

let me know what you think of this

thanks for looking

JR





pepelepew69 is offline  
post #13 of 26 (permalink) Old 11-30-2012, 05:22 AM
GGR
BenzWorld Elite
 
Date registered: Apr 2006
Vehicle: W111 Coupe
Location: Washington DC
Posts: 1,205
Mentioned: 1 Post(s)
Quoted: 19 Post(s)
That's indeed a very beautiful W110. But I'm curious about the rear lights: wasn't the 230 already with the newer more squarish ones?
GGR is offline  
post #14 of 26 (permalink) Old 12-07-2012, 11:24 AM
BenzWorld Junior Member
 
Roadslayer's Avatar
 
Date registered: Dec 2011
Vehicle: S500, S600
Location: The Edge
Posts: 15
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
''OK, so what happened to the Coupe' photos? I just get little boxes that says deleted.


''
Roadslayer is offline  
post #15 of 26 (permalink) Old 12-08-2012, 05:40 PM
BenzWorld Junior Member
 
Date registered: Nov 2006
Location: On Lake Ontario, NY
Posts: 42
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
The cars look great that your Dad restored.

But yes, let's see the pics that disappeared.

Skip
4cammerbenz is offline  
post #16 of 26 (permalink) Old 01-11-2013, 10:29 PM Thread Starter
BenzWorld Member
 
Date registered: Sep 2011
Vehicle: 66 250se coupe w111, 65 600 swb limo, 89 560sl 90k original miles fully documented, 96 e320 280k mil
Location: Los Angeles CA
Posts: 209
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Will post some more pictures up.. I wonder why they got deleted. Or who deleted them.. Tomorrow new pics uo


Sent from my iPhone using AutoGuide.com Free App
pepelepew69 is offline  
post #17 of 26 (permalink) Old 01-12-2013, 03:13 PM Thread Starter
BenzWorld Member
 
Date registered: Sep 2011
Vehicle: 66 250se coupe w111, 65 600 swb limo, 89 560sl 90k original miles fully documented, 96 e320 280k mil
Location: Los Angeles CA
Posts: 209
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
w111 6.3 two tone coupe

enjoy

just took these pictures rite now..
pepelepew69 is offline  
post #18 of 26 (permalink) Old 01-12-2013, 05:06 PM
BenzWorld Junior Member
 
Date registered: Nov 2006
Location: On Lake Ontario, NY
Posts: 42
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
They all look great...thanks for posting.

Any 107/116's?

Skip
4cammerbenz is offline  
post #19 of 26 (permalink) Old 01-12-2013, 05:42 PM
BenzWorld Extremist
 
kavadarci's Avatar
 
Date registered: Aug 2008
Vehicle: 1971 250C
Location: Toronto, Canada
Posts: 1,056
Mentioned: 0 Post(s)
Quoted: 14 Post(s)
Quote:
Originally Posted by pepelepew69 View Post
enjoy

just took these pictures rite now..
I

W
A
N
T

I
T
kavadarci is offline  
post #20 of 26 (permalink) Old 01-12-2013, 05:55 PM
BenzWorld Junior Member
 
Roadslayer's Avatar
 
Date registered: Dec 2011
Vehicle: S500, S600
Location: The Edge
Posts: 15
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Oh God! I'm dyin', dude. I drove a Coupe' from '76 to '92. Some of my 20's, 30's and 40's in that car. Towards the later years I thought seriously of 450'ing it. Even a 6.3. But the poor ol' car just rusted away right before my very eyes. Thank you for reposting more photos. And more tech info would be nice.


'Cheers' Roadslayer
Roadslayer is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome