Tach issues....pegged when turn key? - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 11-07-2012, 04:55 PM Thread Starter
BenzWorld Junior Member
Date registered: Dec 2011
Vehicle: '86 190D 2.5 non-turbo
Location: Alpharetta, GA
Posts: 45
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Tach issues....pegged when turn key?


I've recently noticed that my 1986 190d 2.5's tach pegs full scale when I turn the ignition key to start and then finds its proper mark when the car starts. Then, following roughly 15 to 30 minutes of driving, dies all together.

Your thoughts and comments on this are very much appreciated.


Dan - Alpharetta, GA
Dandi54 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome