W108 3.5 Misfiring Issue - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 11-04-2012, 11:52 AM Thread Starter
BenzWorld Newbie
 
Date registered: Nov 2012
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Unhappy W108 3.5 Misfiring Issue

Hi Folks,

I have recently bought W108, 1972 3.5 V8 which was stored for few years. Have misfiring issue, rough running with black smoke with loads of unburnt fuel.

Following things have been carried out by Mechanic:

1- Compression Test (Equal Pressure in All cylinders)
2- New spark plugs, leads, rotor and distributor Cup
3- New fuel pump
4- 2 New injectors as fuel was leaking out.
5- Spark in all leads

Having taken out spark plugs after misfiring, unburnt fuel and plugs were wet with fuel.

Advice and opinion is needed and would be greatly appreciated for any ideas what could be issue as my mechanic has no idea what else could be wrong.

Regards
miw76 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 11-04-2012, 07:43 PM
BenzWorld Junior Member
 
Date registered: Sep 2012
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Injectors

I would have all of the injectors rebuilt. I had mine done by Injector Rx here in Houston. They are a very nice South African couple.
Mark Aycock is offline  
post #3 of 3 (permalink) Old 11-05-2012, 05:08 PM
BenzWorld Elite
 
Grubeguy's Avatar
 
Date registered: Jan 2006
Vehicle: 73 280SE 4.5, 71 300SEL, 03 BMW Z4, 72 Fiat 850, 80 Triumph TR7, 85 Porsche 911
Location: DC Area
Posts: 2,110
Mentioned: 1 Post(s)
Quoted: 97 Post(s)
Send a message via MSN to Grubeguy Send a message via Yahoo to Grubeguy
Check the trigger points too.

I'm assuming you dumped the old gas and started totally fresh with new stuff?

What about points/condensor? Have you replaced or adjusted? I'd recommend dumping the wole setup and going with a Pertronix setup. MUCH better running.
Grubeguy is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome