Battery issue?? Starter?? - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 05-25-2012, 01:30 PM Thread Starter
BenzWorld Junior Member
 
BlueSkiesWhiteClouds's Avatar
 
Date registered: May 2011
Location: California
Posts: 25
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Battery issue?? Starter??

Hello BW members,
I am having an issue with my 280 and it's inabilty to keep a charge and start every morning..I charged up my battery for hours.. The car starts right up. Overnight it seems to lose it's charge or perhaps the battery is just shot?!! I don't really think it is my starter because as soon as I pull out my portable jumper, it fires right up immediately...

Usually after it has run for a few it will fire right back up but today it doesn't fire back up, it requires me to get out my jumper and again immediately fires right up.. Any ideas before I go into a shop? Thanks all and Happy Memorial..

Last edited by BlueSkiesWhiteClouds; 05-25-2012 at 01:37 PM.
BlueSkiesWhiteClouds is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 05-25-2012, 08:59 PM
BenzWorld Member
 
Date registered: Jul 2009
Vehicle: 1964 Mercedes 220Sb
Location: Muskegon, Michigan
Posts: 103
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
It's not the starter, I'd replace the battery and see if that fixes your problem.

With the hot weather many batteries are failing, it's extremely common to see a ton of posts about failing batteries in the beginning of summer.

(and just jump starting the car is putting a lot of strain on the alternator's voltage regulator, I'd recommend replacing the battery before you cook your voltage reg.)
tgikal is offline  
post #3 of 8 (permalink) Old 05-25-2012, 10:58 PM Thread Starter
BenzWorld Junior Member
 
BlueSkiesWhiteClouds's Avatar
 
Date registered: May 2011
Location: California
Posts: 25
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks...just charged the battery and it fired right up..I guess we'll find out in the morning....I will probably go out and purchase a new battery just for good measure considering i've left the lights on 4 or 5 times causing DEAD BATTERY...
BlueSkiesWhiteClouds is offline  
post #4 of 8 (permalink) Old 05-26-2012, 12:09 AM
BenzWorld Member
 
Date registered: Jun 2009
Posts: 244
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Battery's probably dead. Better have your electricals checked also in case you have a grounded wire somewhere causing the overnight drain.
ijiwaru is offline  
post #5 of 8 (permalink) Old 04-29-2014, 10:15 AM
BenzWorld Junior Member
 
Date registered: Jun 2009
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I went through 2 batteries on my 280C, each lasting only a year. The problem was a short. Also be sure your positive cable is bolted to the positive post. It will start (for a while) if connected wrong. Someone previous had put in a new cable and they were both marked positive.
280c75 is offline  
post #6 of 8 (permalink) Old 04-29-2014, 07:08 PM
BenzWorld Elite
 
Grubeguy's Avatar
 
Date registered: Jan 2006
Vehicle: 73 280SE 4.5, 71 300SEL, 03 BMW Z4, 72 Fiat 850, 80 Triumph TR7, 85 Porsche 911
Location: DC Area
Posts: 2,110
Mentioned: 1 Post(s)
Quoted: 97 Post(s)
Send a message via MSN to Grubeguy Send a message via Yahoo to Grubeguy
Quote:
Originally Posted by 280c75 View Post
Also be sure your positive cable is bolted to the positive post. It will start (for a while) if connected wrong.
If by this, do you mean the cables reversed - negative (ground) wire to the positive battery post, and the main cable to the negative battery post? The car won't start at all - it'll most likely destroy the wiring harness after a good electrical fire starts.
Grubeguy is offline  
post #7 of 8 (permalink) Old 04-30-2014, 07:51 AM
BenzWorld Junior Member
 
Date registered: Jun 2009
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Sorry to differ, but, yes, it does start. There was another post back awhile which agreed that it will start. Do you own a 1975 or older?
280c75 is offline  
post #8 of 8 (permalink) Old 04-30-2014, 09:16 AM
Premium Member
 
Date registered: Nov 2012
Posts: 1,241
Mentioned: 0 Post(s)
Quoted: 59 Post(s)
Premium Member
i you want to see if it is the battery , disconnect it the night before , and reconnected in the morning , if car starts fine , it is not the battery .it is critical that you say what year the car is , 76 on has a problem with the climate control that will drain your battery over nite .
agillot is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Massive headache: Starter Motor / Battery / Alternator issue Qualm W124 E,CE,D,TD Class 11 09-14-2011 03:29 AM
    Starter issue? Vector_03 C215 CL-Class 7 11-15-2010 09:26 PM
    80' 240D either alternator or starter issue, battery dies quickly. Gvigorus W123 E,CE,D,CD,TD,TE Class 14 10-08-2007 09:44 AM
    Starter issue kef W123 E,CE,D,CD,TD,TE Class 2 07-08-2007 07:32 PM
    Alternator/Starter/Battery cable issue Gvigorus W123 E,CE,D,CD,TD,TE Class 26 11-10-2005 02:21 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome