Has Anyone Installed a Vaico Fuel Pump? - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 01-05-2012, 03:07 PM Thread Starter
BenzWorld Veteran
 
Date registered: Nov 2008
Vehicle: 1981 300TD 310k--1966 230 165k--1970 280se 172k
Location: Ohio City, Ohio
Posts: 636
Mentioned: 1 Post(s)
Quoted: 37 Post(s)
(Thread Starter)
Has Anyone Installed a Vaico Fuel Pump?

I wanted to replace my fuel pump on my m180.945 engine but couldn't find a Pierberg which is OEM. So I bought a Vaico brand pump. It looks cheap (and it was cheap) but I figured it would be better than the old one I had on the car.

I installed it today and it leaks a good deal of oil out the weep hole on the bottom of the pump. I verified that it wasn't leaking around the gaskets with a mirror.

So my questions are these: can I plug the weep hole with something to stop the leaking (the car runs fine with this pump), or does the weep hole need to breathe for proper operation of the pump? Should I just take my chances and put the original pump back on, figuring the Vaico is just another crappy aftermarket part?

The main reason I'm replacing the original pump is that gas drains down out of the line when the car sits. It takes 5 or 6 tries to get it started. I figured the check valve in the pump is weak. I'm fully aware of the evaporation problems my Solex carbs have, but this is ridiculous (and hard on the starter).

1981 300TD--310k miles
1970 280sel--172k miles
1966 230--162k miles
carpenterman is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Fuel Pump, Fuel Pump Relay or something else? W126fahrer W126 S,SE,SEC,SEL,SD,SDL Class 24 10-24-2013 08:03 AM
Primer pump won't pump. No fuel coming to pre filter. Dieselache W123 E,CE,D,CD,TD,TE Class 3 06-16-2011 04:55 AM
Installed new fuel pump - pictures Ramesh W126 S,SE,SEC,SEL,SD,SDL Class 21 08-17-2006 03:15 PM
380sel where is the fuel pump fuse? have no power to pump meggala W126 S,SE,SEC,SEL,SD,SDL Class 3 08-02-2005 03:44 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome