1974 280 Backfiring and stalling issue - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 12-13-2011, 12:29 PM Thread Starter
BenzWorld Newbie
Date registered: Dec 2011
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1974 280 Backfiring and stalling issue

I'm new here so forgive me if I have posted this in the wrong forum. If possible, please help:
My 1974 Merc 280 had a problem starting the other day following lots of rain. The next day it started right up and then stalled after a minute. I thought it was an electrical issue so I gave it a new distributor cap, rotor, plugs and wires as well as a new air filter as the old one seemed to have melted a bit. After changing all that it started and ran like a champ until I tried to drive away. It backfired through the carb and stalled. Since then I have gotten it to start again and run for about a minute then it suddenly cuts out as if I turned the key off. Occasionally it will bog down and I can keep it running for a bit by giving it gas but it still stalls in the end. After stalling it needs to rest for a few minutes before it will start again. The choke and carb intake were sticky so I sprayed them with carb cleaner and they seem to be moving fine now. I'm at a loss for what to try next; thinking fuel filter, fuel pump relay, points, coil, carberateur???? Any suggestions would be greatly appreciated, I don't want to have to put it in the graveyard. Thanks in advance.
USA 1974 280 is offline  
Sponsored Links
post #2 of 5 (permalink) Old 12-13-2011, 01:36 PM
BenzWorld Junior Member
Date registered: Jun 2011
Vehicle: 1980 280E
Location: Central california
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Ok here is what I would check in general with any car having this issue. Have someone start it for you and be at the back of the car. Is there black smoke? White smoke or does it have a funny smell? You mentioned it rained just before this issue so you may have water in the gas. To check fuel flow (which will help determine fuel filter plugged or bad pumP) disconnect the fuel line from the carb. Place it in a quart jar and crank over the engine for 1 minute and see how much fuel is in the jar. Then let it sit for a day if there is water in it it will seperate.
benzotom is offline  
post #3 of 5 (permalink) Old 12-13-2011, 02:17 PM Thread Starter
BenzWorld Newbie
Date registered: Dec 2011
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks Benzotom,
Normally there is a bit of white smoke that comes out the exhaust but only when it first starts. Question: Could the fuel filter be clogged in a way to let it run for a minute and then cut out (creates a vaccuum in the fuel line)? And if so, would this cause it to backfire out of the carb?
USA 1974 280 is offline  
post #4 of 5 (permalink) Old 12-13-2011, 10:20 PM
BenzWorld Member
Date registered: Mar 2011
Vehicle: 1971 250/8 sedan with 80 K miles. Driven only in Summer.
Location: Vancouver BC Canada
Posts: 107
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
You should also check the timing and dwell on your engine and your fuel filter should be replaced regardless. Just trying to help. Harald.
Over 75 is offline  
post #5 of 5 (permalink) Old 12-15-2011, 12:07 AM
BenzWorld Senior Member
drew56cus's Avatar
Date registered: Oct 2006
Vehicle: 1965 220SE sedan (finnie) with 450SE conversion, 1964 220SE coupe project, 1966 300SE coupe
Location: Brisbane Australia
Posts: 411
Mentioned: 1 Post(s)
Quoted: 32 Post(s)
I had a case once where I could putt around slowly but if I drove quickly the car died. After a minute, I coudl start it back up and putt around again. After checking/changing pretty much everything, I checked the muffler - it had collapsed inside so would not let the exhaust out quickly enough when the car was under load.
Cheers, Drew
drew56cus is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    The old stalling issue..... Huudat_AMG W210 E50 AMG, E55 AMG 9 10-25-2011 03:15 AM
    Another stalling issue Dudecz190 W201 190-Class 12 10-20-2011 09:39 PM
    Help with stalling issue..... harleyguy92887 W140 S-Class 2 04-26-2011 07:21 AM
    V12 stalling issue south W140 S-Class 15 07-12-2010 06:41 PM
    98 SL500 stalling issue Dimitris R129 SL-Class 14 04-16-2010 07:21 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome