1977 230 w123 chassis horn stopped working - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 10-18-2011, 07:46 PM Thread Starter
BenzWorld Member
 
Date registered: May 2011
Vehicle: 1970 Mercedes 250c, 1977 mercedes 230 (put to rest at a junyard she served me well)
Location: Great Barrington, MA
Posts: 57
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1977 230 w123 chassis horn stopped working

I have a manual for this car but it doesn't seem to have anything on the horn.

It just stopped working one day, I was driving, I honked at someone, and 5 minutes later I pressed the horn again and it did nothing.

Anyone have any info on w123 horns? Repair manual?

Ideas?
makinfrenzinmybenz is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Help! Horn stopped working! 84Euro500SEL W126 S,SE,SEC,SEL,SD,SDL Class 0 07-12-2010 12:16 PM
my horn has stopped working gelsi W201 190-Class 2 02-07-2010 02:29 PM
Horn stopped working SilverSEL W126 S,SE,SEC,SEL,SD,SDL Class 11 11-04-2009 02:33 PM
Horn just stopped working 500s VenezuelaBenz W140 S-Class 1 04-18-2005 04:39 AM
Horn stopped working Guest (MBNZ) W124 E,CE,D,TD Class 0 04-24-2002 12:18 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome