'76 300d transmission issue... - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-16-2011, 06:07 AM Thread Starter
BenzWorld Junior Member
Date registered: Mar 2011
Posts: 13
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
'76 300d transmission issue...

So i recently changed the ATF and filter in the auto tranny on my 76 w115 300d....which i was recently told was not a very good idea...and recently i would be cruising at about 30-40 mph and the engine would start revving as though my left foot was accidentally depressing the clutch...only there is no clutch as its an auto...the guy i spoke with who said changing the fluid was a bad idea suggested adding a bottle or two of Lucas transmission fix...a much heavier weight ATF...can't say i've noticed an improvement.....

just wondering if any of you out there have any advice on what the problem could be or if any of you have been in the same situation?

ianfotheringham is offline  
Sponsored Links
post #2 of 3 (permalink) Old 10-16-2011, 06:52 AM
BenzWorld Elite
flyboyike's Avatar
Date registered: May 2003
Vehicle: 2012 Focus SE
Location: Ormond Beach, FL
Posts: 7,697
Mentioned: 1 Post(s)
Quoted: 67 Post(s)
Does it do that all the time or is it intermittent?

Felicita e un bicchiere di vino con un panino.
flyboyike is offline  
post #3 of 3 (permalink) Old 10-16-2011, 06:54 AM Thread Starter
BenzWorld Junior Member
Date registered: Mar 2011
Posts: 13
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
its intermittent - and usually only in the first few miles once started from cold....then goes away....till the next morning...
ianfotheringham is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    1983 300D New Transmission electronic connector issue Billynok W123 E,CE,D,CD,TD,TE Class 1 05-04-2011 12:47 PM
    Will this 79 300D Wagon transmission fit my 81 300D Sedan? sshanky W123 E,CE,D,CD,TD,TE Class 0 12-16-2010 11:37 PM
    Starting issue 85 300D DAP W123 E,CE,D,CD,TD,TE Class 62 05-09-2009 05:18 PM
    Shifting issue in my 76 300D matthend Vintage Mercedes-Benz 1 02-26-2005 05:31 AM
    300D Transmission Issue Joey W123 E,CE,D,CD,TD,TE Class 2 01-08-2004 08:30 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome