Sls valve not working? - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 10-14-2011, 05:42 PM Thread Starter
BenzWorld Newbie
Date registered: Oct 2011
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Sls valve not working?

Hi, I have a w123 wagon that I just got. The back sags like crazy and it is apparent that the self leveling suspension is not working. The pump seems to work because fluid is being returned to the reservoir but in a steady stream not very fast. The valve was disconnected from the sway bar and when I tried to operate it by hand it moved freely and didnt move the shocks up or down. The valve did not give any resistance. I am ordering the necessary components to attach the valve lever back to the sway bar. What should I do next? Thanks in advance. - jim
huck finns buddy jim is offline  
Sponsored Links
post #2 of 2 (permalink) Old 10-15-2011, 04:25 AM
BenzWorld Elite
flyboyike's Avatar
Date registered: May 2003
Vehicle: 2012 Focus SE
Location: Ormond Beach, FL
Posts: 7,697
Mentioned: 1 Post(s)
Quoted: 67 Post(s)
Check the accumulators, they probably failed first, and everything else followed. Fortunately, they're relatively inexpensive.

Your Parts Search Returned 1 Part(s)

Also, see our W123 forum for gobs and gobs of knowledge on this and many other issues.

Felicita e un bicchiere di vino con un panino.
flyboyike is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    question on air check valve/ shut off valve shaunt R170 SLK-Class 6 12-29-2010 01:08 AM
    Where can I buy a working VCV valve?? BioNerd W123 E,CE,D,CD,TD,TE Class 1 11-13-2010 08:25 AM
    Idle control valve/air slide valve question dcrews R/C107 SL/SLC Class 5 05-24-2010 01:54 AM
    Working without a manual this weekend: front brakes / valve cover gasket. Any suggestions? 71Rcode W124 E,CE,D,TD Class 9 03-07-2004 07:30 AM
    Idle valve = Cold Start Valve ? maxhofer W123 E,CE,D,CD,TD,TE Class 1 01-27-2003 01:26 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome