help with w115 wiper foot pump trouble shooting - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-13-2011, 12:47 AM Thread Starter
BenzWorld Newbie
 
Date registered: May 2007
Vehicle: 84 280GE
Location: Berkeley, CA
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
help with w115 wiper foot pump trouble shooting

Hi,
I'm trying to figure out why my water jets aren't working on my 115.117.
the pump appears to pump, the tank looks great.

I see a white little manifold on the firewall that could be a check valve.
if that's what it is, then I suspect it's the culprit. as the bottom inlet appears to be blocked in either direction of pressure.

is this something I should just poke at til it works? I just did some searching and couldn't find a source for a new one.
syncro is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 10-13-2011, 06:27 AM
BenzWorld Elite
 
Govert70227's Avatar
 
Date registered: Oct 2009
Vehicle: 2000 VW Golf Variant
Location: Leiden, Netherlands
Posts: 2,952
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
The water jet system works with a foot pump, a valve on top of the water reservoir and a check valve in the tube to the water jets, to prevent the system from draining.

If you disconnect the tube to the jets, and pump the foot pump, it should pump water. Than the check valve is the culprit. You can try poking it, but it can also be replaced, it is not that expensive.
Govert70227 is offline  
post #3 of 3 (permalink) Old 10-13-2011, 11:28 PM Thread Starter
BenzWorld Newbie
 
Date registered: May 2007
Vehicle: 84 280GE
Location: Berkeley, CA
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks, I just priced it out a classic center. It's cheap enough to add to my door seal order.
syncro is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Need some trouble shooting help. Herbie3Rivers W123 E,CE,D,CD,TD,TE Class 5 01-14-2010 06:34 PM
    Trouble shooting ABC/Pwr Steering rtgogo C215 CL-Class 10 12-13-2009 04:57 PM
    Help trouble shooting Low Range silver Inspiration W163 M-Class 6 10-06-2009 09:11 AM
    404 Gas Tank Trouble Shooting raabta01 Unimog 9 04-25-2007 12:26 PM
    trouble-shooting PART II nobby R/C107 SL/SLC Class 15 02-19-2006 12:21 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome