my 66 and maintaining speed on highway - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 10-03-2011, 08:55 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Oct 2011
Vehicle: Two Tone Blue and White 1966 Mercedes Benz 200 Sedan
Location: Cape May, NJ
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via AIM to briantsosie
(Thread Starter)
Question my 66 and maintaining speed on highway

I just bought a 1996 mercedes benz sedan. I am having trouble on the highway. The first 15 miles are great, but then I start feeling loss of power while trying to maintain speed. I have the pedal down, but the power comes in surges. Does anyone have any idea what I need to replace? I am new to this, any suggestion would help. Thank you so much.
briantsosie is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 10-03-2011, 10:28 AM
Lifetime Premium Member
 
Scoot's Avatar
 
Date registered: Oct 2002
Vehicle: 1967 250 SL, 1963 220Sb
Location: Los Angeles / Altadena
Posts: 2,590
Mentioned: 3 Post(s)
Quoted: 103 Post(s)
Lifetime Premium Member
I would try replacing the fuel filter.

Currently: 1967 250 SL, 1963 220Sb, 1965 300SE Lang, 1971 280SE parts car, 1972 Alfa GTV, 1965 Alfa Duetto, 1993 BMW R100R
Past: 1971 250 C, 1985 300 TD, 1967 250 S, 1968 280 S,1981 300 D, 1982 280CE, 3 Facel Vegas, Borgward Isabella Coupe, Alfa 2600 Sprint, Volvo P1900 (yes), numerous less interesting Volvos, ...
Scoot is offline  
post #3 of 10 (permalink) Old 10-03-2011, 02:36 PM
BenzWorld Elite
 
flyboyike's Avatar
 
Date registered: May 2003
Vehicle: 2012 Focus SE
Location: Ormond Beach, FL
Posts: 7,699
Mentioned: 1 Post(s)
Quoted: 68 Post(s)
Quote:
Originally Posted by briantsosie View Post
I just bought a 1996 mercedes benz sedan. I am having trouble on the highway. The first 15 miles are great, but then I start feeling loss of power while trying to maintain speed. I have the pedal down, but the power comes in surges. Does anyone have any idea what I need to replace? I am new to this, any suggestion would help. Thank you so much.
Gas or diesel?

Felicita e un bicchiere di vino con un panino.
flyboyike is offline  
post #4 of 10 (permalink) Old 10-03-2011, 02:38 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Oct 2011
Vehicle: Two Tone Blue and White 1966 Mercedes Benz 200 Sedan
Location: Cape May, NJ
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via AIM to briantsosie
(Thread Starter)
its regular gas. 200
briantsosie is offline  
post #5 of 10 (permalink) Old 10-03-2011, 02:43 PM
BenzWorld Elite
 
flyboyike's Avatar
 
Date registered: May 2003
Vehicle: 2012 Focus SE
Location: Ormond Beach, FL
Posts: 7,699
Mentioned: 1 Post(s)
Quoted: 68 Post(s)
Quote:
Originally Posted by briantsosie View Post
its regular gas. 200
Then I would agree with Scoot, start with the easy stuff like the fuel filter. When was the last tuneup, any idea?

Felicita e un bicchiere di vino con un panino.
flyboyike is offline  
post #6 of 10 (permalink) Old 10-03-2011, 02:47 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Oct 2011
Vehicle: Two Tone Blue and White 1966 Mercedes Benz 200 Sedan
Location: Cape May, NJ
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via AIM to briantsosie
(Thread Starter)
i have paperwork somewhere, but i just got it this week. i made an appointment to have it looked at tomorrow. thanks guys, ill keep ya posted.
briantsosie is offline  
post #7 of 10 (permalink) Old 10-03-2011, 02:51 PM
BenzWorld Elite
 
flyboyike's Avatar
 
Date registered: May 2003
Vehicle: 2012 Focus SE
Location: Ormond Beach, FL
Posts: 7,699
Mentioned: 1 Post(s)
Quoted: 68 Post(s)
It's always a good idea, especially with a car that old, to do a comprehensive service (all fluids, all filters, plugs, wires, cap, rotor, thorough carb cleaning, brake bleed etc) just so you can be sure what is good. Then if the car still has issues, you can eliminate a whole bunch of suspects.

Felicita e un bicchiere di vino con un panino.
flyboyike is offline  
post #8 of 10 (permalink) Old 10-03-2011, 05:26 PM
BenzWorld Veteran
 
Date registered: Nov 2008
Vehicle: 1981 300TD 310k--1966 230 165k--1970 280se 172k
Location: Ohio City, Ohio
Posts: 624
Mentioned: 1 Post(s)
Quoted: 33 Post(s)
If a new filter doesn't clear it up, I'd check the tank screen, then the fuel pump.

1981 300TD--310k miles
1970 280sel--172k miles
1966 230--162k miles
carpenterman is offline  
post #9 of 10 (permalink) Old 01-12-2012, 07:48 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Oct 2011
Vehicle: Two Tone Blue and White 1966 Mercedes Benz 200 Sedan
Location: Cape May, NJ
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via AIM to briantsosie
(Thread Starter)
Thanks for all your advice guys. There was a leak in the fuel line which I have had addressed. As soon as that was repaired its something else. I tried to start her up one day and the clutch pedal fell quickly to the floor and wont pop back. It feels like a spring has failed or something. Does anyone have an idea what it could be this time?
briantsosie is offline  
post #10 of 10 (permalink) Old 01-13-2012, 04:56 AM
BenzWorld Elite
 
wbain's Avatar
 
Date registered: Dec 2003
Vehicle: 1965 220S, 1999 Volvo V70 (wagon), 2006 Ford Crown Vic Police Interceptor, 72 350SL 4 Speed
Location: Near Manassas Va.
Posts: 1,830
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
You have air in the system or it's leaking at the slave cyl. Given the age of the car, get the slave cyl overhaul kit, a new hose, and the short hose from the reservoir to the pipe. Use a hone to clean the cyl as well. While your at it, get a replacement master cyl as well, a complete overhaul.

You then have to bleed it from below, the slave cyl. I used a power bleeder.

Near Manassas Va. '65 220S, 2006 Ford Crown Victoria Police Interceptor, '99 Volvo V70, '72 350SL 4 speed

Not part of the in-crowd since 1952. It's BRAKES not breaks. You break a bone, use brakes to stop your car. /rant

http://www.megamanual.com/index.html
http://www.bgsoflex.com/megasquirt.html
wbain is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Vibration at highway speed and a rumble! zimsc350 W203 C-Class 1 07-26-2011 08:32 PM
    Strange noise while maintaining speed falling angel W123 E,CE,D,CD,TD,TE Class 5 04-28-2010 01:44 AM
    Problems with speed on highway rykappes W123 E,CE,D,CD,TD,TE Class 4 12-23-2008 06:18 AM
    Best highway cruising speed? rabendan W124 E,CE,D,TD Class 13 02-14-2008 03:07 AM
    Why would my 420 run hotter at highway speed? guarddog W126 S,SE,SEC,SEL,SD,SDL Class 6 08-09-2007 06:29 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome