1988 300 CE electrical problems. PLEASE HELP! - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-01-2011, 05:18 PM Thread Starter
BenzWorld Junior Member
Date registered: Oct 2011
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1988 300 CE electrical problems. PLEASE HELP!

So, I recently purchased my 1988 300 CE a few months ago, which was "highly used" by the way. Anyway, the car had a very old CD changer in it and I'm not sure if it was factory or after market. So a few weeks ago, the CD changer went completely out, but I had an aftermarket CD player I took out of my old car and I had it installed in the Benz. After installation of the new CD player, I noticed that whenever I let down the windows in my car, the speakers go in and out. At first it was just right side (which were already out, but when I pressed the window button would the right side would come back in and go out again), and now ALL the speakers go extremely low when I press the button.

After this happened, the ABS light came on and would not go off. THE NEXT thing that happened was yesterday. I went to my car and started it, and it cut right back off again. After doing this several times, it finally started and stayed on when I revved the engine when I cranked it. Then while I was driving when I finally it running, the engine started idling very high. It sounded like I was revving up the engine when I was in park or on the brakes.

Does ANYBODY know what could be going on right now? I'm really nervous because I bought this car because I really had no other choice and I really don't have a "Benz maintenance budget" and I'm just nervous that this is something big that I'm not going to be able to handle
Benz_300CE is offline  
Sponsored Links
post #2 of 3 (permalink) Old 10-01-2011, 05:44 PM
BenzWorld Elite
flyboyike's Avatar
Date registered: May 2003
Vehicle: 2012 Focus SE
Location: Ormond Beach, FL
Posts: 7,697
Mentioned: 1 Post(s)
Quoted: 67 Post(s)
Originally Posted by Benz_300CE View Post

Does ANYBODY know what could be going on right now?
Yes, somebody in the W124 forum probably does.

Felicita e un bicchiere di vino con un panino.
flyboyike is offline  
post #3 of 3 (permalink) Old 10-02-2011, 05:54 AM
BenzWorld Elite
wbain's Avatar
Date registered: Dec 2003
Vehicle: 1965 220S, 1999 Volvo V70 (wagon), 2006 Ford Crown Vic Police Interceptor, 72 350SL 4 Speed
Location: Near Manassas Va.
Posts: 1,830
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Personally, I would replace the radio with a modern one that has IPOD control. The CD changer would be tossed as well.

The radio in my daily driver is a SONY with HD radio, USB input, AUX input and IPOD control.

Near Manassas Va. '65 220S, 2006 Ford Crown Victoria Police Interceptor, '99 Volvo V70, '72 350SL 4 speed

Not part of the in-crowd since 1952. It's BRAKES not breaks. You break a bone, use brakes to stop your car. /rant

wbain is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    1988 300CE - Strange electrical problems Please Help!! James1980 W124 E,CE,D,TD Class 7 07-18-2011 09:17 AM
    electrical problems on a 1988 560sl britguy R/C107 SL/SLC Class 4 05-22-2009 06:01 AM
    1988 560 sl electrical problem britguy R/C107 SL/SLC Class 3 04-29-2009 05:59 AM
    No start...electrical? 1988 190e montaukbeachboy W201 190-Class 4 05-07-2005 05:02 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome