Help!!Mice using my blower motor as a home. - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-28-2011, 10:38 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Oct 2010
Vehicle: 1975 300D W115
Location: Nova Scotia
Posts: 36
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Help!!Mice using my blower motor as a home.

Went for a drive yesterday, turned the blower on and you should have seen the material that came out of the vents!!!

When I got home I began to vacuum out what I could. I took out the dash speaker to see if I could get at the central vent; this is where I need some help.

I am assuming I will have to take the entire system apart. Is there a procedure for this? Once apart, are there any recommendations for preventative maintenance?

Thanks,

Marc-André
maclaveau is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 06-29-2011, 09:03 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Oct 2010
Vehicle: 1975 300D W115
Location: Nova Scotia
Posts: 36
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
I believe I found where the mouse may have got in. There appears to be 3 drain holes on the fire wall, 2 have flaps, the middle one does not and looks like a challenge to get at (Is it suposed to have one?). Does anyone know where to purchase one of this?

Thanks,
maclaveau is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Blower not working but blower motor fine what to check next? classicchic W123 E,CE,D,CD,TD,TE Class 20 05-07-2014 06:56 PM
    W126 separate blower from blower motor? curtesy W126 S,SE,SEC,SEL,SD,SDL Class 6 02-02-2013 03:21 PM
    1998 W210 E300DT Bad Blower Regulator or Blower Motor?? How to tell DieselNuts W210 E-Class 12 08-16-2012 10:32 AM
    Blower Motor + Burning Smell = No Blower Motor nuts2that W210 E-Class 6 07-28-2010 02:07 AM
    Wiper Motor or Blower Motor / Resistor Pack Failure?? jangr320 W163 M-Class 3 11-13-2004 12:20 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome