1981 Mercedes 380 SLC new engine wont run above idle - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-21-2011, 09:41 AM Thread Starter
BenzWorld Newbie
Date registered: Jun 2011
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Angry 1981 Mercedes 380 SLC new engine wont run above idle

Hello! I have recently purchased a 1981 380slc. It was DOA, with a locked up motor. I bought a 380se shortblock motor with redone heads and dual row timing chain. I have done my best to route the vacuum lines using a schematic from this forum. The car will run at idle, only whith the cold start injector energized. I have replaced the fuel distributor, no difference, fuel pump and componants, no difference, I am jumping the voltage overload relay (new one on order) there was no power to the ecu/idle control, that was the culprit. When I jump the fuel pump and press down on the air flow sensor I get fuel out of all distributor outlets. Last night I had it idleing smoothly with the CSV jumped, but this moring it was only running on the pass side of engine. It's got to be a fuel delivery issue- I have NOT replaced the WUR, also the vacuum line from the pressure regulator is going the the air cleaner hose vacuum connection. I have not replaced the pressure reg. The air injection valve seems to work as well. I was going to check for vacuum leaks this morning, but thats when it started running on only one side..pulled the front plug it was dry. In addition I'm using a manifold off a later 380, that has holes in the top, where as the original has caps on these holes. Everything els is the same. This car is kicking my butt! Anyone?

Last edited by atomices; 06-21-2011 at 09:43 AM.
atomices is offline  
Sponsored Links
post #2 of 3 (permalink) Old 06-21-2011, 01:21 PM
Lifetime Premium Member
Date registered: Sep 2008
Vehicle: 1975 450SL
Location: Phoenix
Posts: 2,432
Mentioned: 2 Post(s)
Quoted: 15 Post(s)
Lifetime Premium Member
The Bosch K-Jet system is notoriously dependant on fuel system pressure, something in the high 70's if I remember correctly. You may need to get a correct fuel pressure gauge to verify that yours is sufficient. The injectors are designed to hold until a certain pressure, then open. You may have low pressure, obstructed lines, plugged injectors, or possibly a bad fuel accumulator.

You might want to go over to the 107 forum to ask further, as there are a lot of people with a lot of knowledge there.

Remember: It's not just a car. It's an Adventure.
RadioTek is offline  
post #3 of 3 (permalink) Old 06-21-2011, 03:58 PM Thread Starter
BenzWorld Newbie
Date registered: Jun 2011
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
fuel accumulator

Thanks for the reply!, One thing I did not do is blow out the lines, the tank was empty but there could be gunk in the lines..I'll also post in the 107 forum like you suggest. I'll remove the tank and alternate air and carb cleaner through the lines and make shure it come through clean. Any recommendation for a fuel PSI tester, and where would I"T" it in? PS is the accumulator back with the fuel pump? Thanks
atomices is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    One wheel wont turn! 1981 300d boomerbust W123 E,CE,D,CD,TD,TE Class 5 04-07-2011 09:54 AM
    1981 Mercedes 300D Engine Mystery... dinoseer General Mercedes-Benz 2 09-09-2010 07:33 PM
    1981 300sd wont shift into 4th, unless vacuum line is off. Benznoob26 W126 S,SE,SEC,SEL,SD,SDL Class 4 07-09-2010 08:28 PM
    Key wont turn on 1981 300sd paparoach W126 S,SE,SEC,SEL,SD,SDL Class 4 06-16-2009 02:22 AM
    1981 380SL Idle Problem xccman R/C107 SL/SLC Class 6 01-26-2005 04:01 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome