w108 280se Heat and coolant problem!! - Page 2 - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #11 of 11 (permalink) Old 12-16-2010, 02:12 PM Thread Starter
BenzWorld Veteran
 
Date registered: Feb 2010
Vehicle: 1968 250SE S-Class. 1988 560SEC S-Class Widebody
Location: SD --> Chicago
Posts: 689
Mentioned: 0 Post(s)
Quoted: 57 Post(s)
(Thread Starter)
Oil is all good, had the system pressure tested, no problems.

i topped it up b4 the mechanic, no leaks, no smokey exhuast. temp stayed under 200 on a 45 min drive there.

he checked the whole system and seems ok.

it warms up a bit at lights but nothing i cant live with. might look at radiator if problem gets worse but seems to be ok for now

got my brake fluid and a tune up. car is running GREAT. thanks all for the advise, helps me learn. good stuff
D&WCali is offline  
Sponsored Links
Advertisement
 
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
HEAT problem and my coolant nsupra W210 E-Class 7 01-31-2010 05:07 AM
Connection problem of w109 6.3 tachometer in w108 280SE 4.5 Jazzenco Vintage Mercedes-Benz 1 09-24-2009 12:13 PM
280SE W108 Project killboy Vintage Mercedes-Benz 13 07-27-2006 06:14 PM
280SE (W108) - Am I mad? cathryn Vintage Mercedes-Benz 5 10-22-2005 04:34 PM
1972 W108 280SE 3.5 Distributor setting problem Guest (MBNZ) General Mercedes-Benz 2 02-15-2001 03:26 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome