Which power for Pertonix ignition - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 10-23-2010, 09:35 PM Thread Starter
BenzWorld Member
 
TZ_280SEL's Avatar
 
Date registered: Feb 2010
Vehicle: 1972 280SEL daily driver. 904 Dark Blue with cognac interior. euro 4.5 engine
Location: Williamsburg, VA
Posts: 317
Mentioned: 3 Post(s)
Quoted: 35 Post(s)
(Thread Starter)
Which power for Pertonix ignition

I know there are several threads about retrofitting Pertronix onto vintage Mercedes, but I have a specific question I can not find.
I have a '72 280SEL4.5 that seems to have suffered ignition module failure. Voltage to the primary of the coil does not change when the points open. I am ordering the Pertronix 1885 module with the flamethrower coil. I am obviously replacing the MB module since it is bad.
Question is, the new Pertronix does not need the ballast resistor in series so the 12v power source can go straight to the + of the coil, but what do I do with the other power source to the existing module. There is the 12V from the ignitin switch which feeds through the resistor, and the 12V from the starter relay that supplies 12V bypassing the resistor during cranking. For those who have done this conversion, I assume youran the 12v from the switch to the coil, but what did you do with the 12V from the starter relay? Pertronix says not to leave the ballast resistor in the source.
Any other issues with the 1885 Pertronix swap I should be aware of?

Thanks
TZ_280SEL is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 10-24-2010, 01:11 AM
BenzWorld Member
 
Date registered: Jun 2010
Vehicle: 1966 MB 200; Porsche 914 (6); Porsche 914 (Chev 350); 36 ford
Location: Sunnyvale, CA
Posts: 348
Mentioned: 0 Post(s)
Quoted: 18 Post(s)
Make sure you are using the correct coil for your ignitor. If I remember, the series I ignitor requires the 3 ohm coil Check to be sure, don't trust my memory.

-- brett
bfrymire is offline  
post #3 of 4 (permalink) Old 10-27-2010, 07:37 PM Thread Starter
BenzWorld Member
 
TZ_280SEL's Avatar
 
Date registered: Feb 2010
Vehicle: 1972 280SEL daily driver. 904 Dark Blue with cognac interior. euro 4.5 engine
Location: Williamsburg, VA
Posts: 317
Mentioned: 3 Post(s)
Quoted: 35 Post(s)
(Thread Starter)
Got my new ignition today in the mail. Took a bit longer to install (about an hour total) because the leads supplied with the pertronix were too short to reach the coil so with a bit of splice, heat shrink and some wire loom, all was in place. The Pertronix installation says to use the 1.5ohm coil with V-8s without a ballast resistor. I have completely removed the MB black box and all ballast resistors. I am using the 12V supply from the ignition switch as power to the + of the coil as well as the Pertronix. Other Pertonix lead to the - side of the coil. Taped up the other 12V supply from the starter relay as it is no longer needed.

She fired up on the first crank. idles great and has more power. I did have to adjust the idle way down because it was very high. I think the old girl was struggling to stay running for a while with the old ignition.

Thanks for the help.
TZ_280SEL is offline  
post #4 of 4 (permalink) Old 10-28-2010, 01:31 PM
BenzWorld Junior Member
 
Date registered: Oct 2010
Posts: 42
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Ign mod

Good to hear it worked out well. I used the adapter sold by Hot Spark. As far as your ignigtion module and resistor, take it out, put it on ebay or trash it you dont have to worry about it again
curtisl is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    no power to ignition starter relay jmj200e W124 E,CE,D,TD Class 5 01-15-2013 06:30 AM
    Tapping into ignition power Samsonite Audio & Telematics Forum 2 01-18-2010 04:49 PM
    tapping ignition power Samsonite W203 C-Class 1 01-13-2010 09:28 PM
    SatNav still drains power while ignition is off? keyhole C209/A209 CLK-Class 4 03-19-2008 02:58 PM
    Power seats without key in ignition ghitos73 W163 M-Class 4 03-08-2003 11:27 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome