need help!!!! - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 08-27-2010, 12:46 PM Thread Starter
BenzWorld Newbie
 
fastdragger's Avatar
 
Date registered: Aug 2010
Vehicle: 1972 280se 4.5
Location: hespertucky michigan
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Post need help!!!!

I recently obtained a 1972 280se with a 4.5 in it. Car ran great for the first tank of fuel.Took it to work one night, ran great all the way home except for the last mile. I decided to step on it and see exactly what kind of speed the ole girl had in her. Ran it up to about 70mph and let off the throttle and the car started to miss and sputter.I made it back to the yard and decided to check the points on it, every thing looked in order but discovered the vacuum adv unit needed replacing. Put the new one in today but didn't do much for it. Car acts like it is flooded now and barely runs.I was wondering if anyone here can give a shout and help me out. thanks
fastdragger is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 08-27-2010, 02:39 PM
BenzWorld Member
 
Date registered: Apr 2008
Vehicle: 93' 300e 2.8/ 86' 190e 2.3-16v X 3 / 66' 200D fintail
Location: oak harbor , WA
Posts: 83
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Just a guess but you can go through and lube all the joints and linkage maybe something stuck also check all the ports on the intake to see if maybe you have a vacuum leak
Honestly just guessing but that be starting points
veedubfreak86 is offline  
post #3 of 3 (permalink) Old 08-27-2010, 04:31 PM
BenzWorld Elite
 
Grubeguy's Avatar
 
Date registered: Jan 2006
Vehicle: 73 280SE 4.5, 71 300SEL, 03 BMW Z4, 72 Fiat 850, 80 Triumph TR7, 85 Porsche 911
Location: DC Area
Posts: 2,110
Mentioned: 1 Post(s)
Quoted: 95 Post(s)
Send a message via MSN to Grubeguy Send a message via Yahoo to Grubeguy
Take a look at the online resources portion of the forum. I posted a troubleshooting guide for our engines there.
Grubeguy is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome