Something's missing - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-08-2010, 04:43 PM Thread Starter
BenzWorld Member
Date registered: May 2010
Vehicle: 1989 560SL
Location: Memphis, TN. area
Posts: 152
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Something's missing

I am a new owner of a 1979 450SL. It runs fine. The air conditioning will freeze you out. Under the hood, on the passenger side, next to the firewall; something is missing. There are a couple of hoses that are open ended and what look like electrical or multiple vacuum connectors that are hanging loose. The car came from Florida and the previous owner knows nothing. What goes there? Is it part of the heater system or what? I have ordered a book and when it gets here it may tell me but someone out there surely knows what should be there. There is room for a full coffee can sized thing....
GrandpaLarry is offline  
Sponsored Links
post #2 of 2 (permalink) Old 06-09-2010, 10:51 AM
BenzWorld Elite
Date registered: Feb 2008
Vehicle: 2004 W220 (S430) ; 2001 R129 (SL500) Sport
Location: Alabama Gulf Coast--formerly Charlottesville, VA
Posts: 1,335
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Your car is an R107 chassis. There is a forum on this site for owners of the R/C107. Scroll down a bit from the main menu and you'll see the roadster forums. The R/C 107 is the first one there.

I bet there is somebody on that forum who can tell you what's missing under your hood.

Good luck.

"Don't pick a fight with an old man. If he is too old to fight, he'll just kill you."--John Steinbeck
DrJfrmLA is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Something's missing GrandpaLarry R/C107 SL/SLC Class 41 06-11-2010 06:49 AM
    IACV - something's still not right ducatipaso W201 190-Class 6 01-11-2009 10:26 PM
    Something's wrong pmeisel W124 E,CE,D,TD Class 8 12-17-2008 08:44 PM
    Something's missing Dr Seventies W123 E,CE,D,CD,TD,TE Class 3 02-15-2008 08:20 AM
    Something's missing! apkano Benzworld Site issues forum 3 12-24-2007 12:01 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome