79 450SL starting problem - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-03-2010, 09:46 AM Thread Starter
BenzWorld Newbie
 
Date registered: Jun 2010
Vehicle: 1997 E420 Sport AMG
Location: Walnut Creek, Ca
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
79 450SL starting problem

Hi,
I'm working on a 79 450SL. It has an intermittent starting problem. Sometimes it starts then sometimes when you turn the key nothing. If you bang on the starter then it starts again. So I replaced the starter of course and.....same problem! I'm suspecting the ignition switch but if there's a relay in the starting system (not sure if there is?) then I would look at that too. Or maybe a bad positive battery cable?
Any and all replies appreciated!
maxoctane is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 06-07-2010, 08:29 AM
BenzWorld Junior Member
 
Date registered: Feb 2010
Vehicle: 1975 280C
Location: Dallas, TX
Posts: 12
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
battery?

The same thing happened to my 75 280C. I tightened the battery connections and it worked. My battery isn't really the right size, so I think it wiggles and loosens the connection.
KaylaMick is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Help 450sl not starting 450Amg R/C107 SL/SLC Class 9 05-23-2010 11:52 AM
450sl 1974 not starting merc131 R/C107 SL/SLC Class 19 12-07-2009 05:19 AM
450SL sat for over a year. Starting precautions? aero1116 R/C107 SL/SLC Class 11 11-28-2008 08:47 PM
79 450sl starting issue t_silver R/C107 SL/SLC Class 1 06-03-2008 11:14 AM
1975 450SL starting problems PUCHUFLETO R/C107 SL/SLC Class 8 02-16-2008 08:22 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome