1973 280se 4.5 Lost power to fans - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 05-04-2010, 06:33 AM Thread Starter
BenzWorld Newbie
 
Date registered: May 2010
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1973 280se 4.5 Lost power to fans

I don't have any power going to either the heater fan or the air conditioner. Both worked fine last year. Fuses are all good. Is there a relay for these I should know about? Thanks
lowrider005 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 05-09-2010, 03:06 PM
BenzWorld Junior Member
 
Date registered: Jan 2008
Vehicle: 1972 280se 4.5 w108 and 1984 280sel w126 euro
Posts: 41
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Did you check the fuses that are under the hood as opposed to the ones under the dash?
pilotds is offline  
post #3 of 6 (permalink) Old 05-12-2010, 01:02 PM Thread Starter
BenzWorld Newbie
 
Date registered: May 2010
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
The fuses under the hood all checked out, so thats what makes me suspect the relay. I'm just guessing,. electrical is not my best area.
lowrider005 is offline  
 
post #4 of 6 (permalink) Old 05-16-2010, 06:57 PM Thread Starter
BenzWorld Newbie
 
Date registered: May 2010
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
replaced the relay today to the tune of $34, and still no juice.Got power to all the fuses to the relay but nothing at the a/c switch. Any ideas?
lowrider005 is offline  
post #5 of 6 (permalink) Old 05-21-2010, 11:55 AM
BenzWorld Junior Member
 
Date registered: Jan 2008
Vehicle: 1972 280se 4.5 w108 and 1984 280sel w126 euro
Posts: 41
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I had a short on my a/c fan switch and whenever I turned it to a certain speed the fuse would trip. I took apart the fan and a/c knob unit and cleaned all of the contacts. The fan and a/c now works as it should. Perhaps there is some dirt or grime that is preventing the contact being made to turn the fan on. It's pretty easy to take that unit out and inspect/clean.

Dan
pilotds is offline  
post #6 of 6 (permalink) Old 05-23-2010, 08:32 AM Thread Starter
BenzWorld Newbie
 
Date registered: May 2010
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks for the tip. The problem is that there is power to the fuses and relay, but nothing gets to the actual switch. Man, I aint got a clue.
lowrider005 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Bought it. 1973/280SE 4.5 dickz Vintage Mercedes-Benz 13 05-03-2010 01:58 PM
1973 280SE 4.5 rkroelin For Sale/Wanted/Trade/Giveaway 27 03-02-2010 01:43 PM
1973 280SE parts daimlerdiesel For Sale/Wanted/Trade/Giveaway 0 12-11-2008 06:59 PM
For Sale: 1973 280se 4.5 erdavis For Sale/Wanted/Trade/Giveaway 2 05-02-2008 06:52 AM
anything you know about a 1973 280se 4.5 DiTomaso Vintage Mercedes-Benz 8 02-07-2007 06:43 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome