68 280se fuel issue? Help - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 04-01-2010, 02:15 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Apr 2010
Vehicle: 2001 E430, 1987 560SEC, 1968 280SE
Location: Dana Point, CA USA
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
68 280se fuel issue? Help

Hi guys, Just bought a 68' 280se. I think I have a fuel pressure problem but need to be sure. Psi out of the rear pump is minimal. No gauge to give actual number but barely pissing.
Near as I can tell by searching this forum, I think I should have 15+psi?

If this is correct, I think I know the issue but need some verification on that rear pump's pressure.
Thanks
Derek
dtek is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 04-01-2010, 02:39 PM
BenzWorld Member
 
cadurning's Avatar
 
Date registered: Dec 2009
Vehicle: '72 280SE barn find
Location: Magee, MS
Posts: 53
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Yep it's 15psi. The flow is also an issue about 1 gallon per min at the return to the tank.

If it's not broke it dosen't have enough features.
cadurning is offline  
post #3 of 3 (permalink) Old 04-01-2010, 03:47 PM
BenzWorld Veteran
 
Date registered: Jun 2004
Posts: 723
Mentioned: 1 Post(s)
Quoted: 17 Post(s)
Sounds like a blockage from the tank. If the pump actually moves fuel it will be OK.
If you can get a minimum of 10 PSI, that will be enough pressure but volume is the critical factor.
It's 1 liter in 15 seconds measured at the cold start valve.
mercmad6.3 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
electrical issue on 1970 280SE edroth17 Vintage Mercedes-Benz 2 07-28-2008 07:20 PM
Hot start issue, 79 280SE rabbit188 W116 S, SE, SEL, SD Class 11 10-22-2007 01:20 AM
Fuel filter before or after fuel pump on 1972 280SE? Floydf Vintage Mercedes-Benz 6 10-19-2006 09:09 AM
metal fuel line CIS fuel injection 79 280se w116 rfitts46 W116 S, SE, SEL, SD Class 0 01-28-2006 02:37 PM
78 280SE Mutiple Idle/start issue...Related? wdba123190 Vintage Mercedes-Benz 5 07-06-2004 02:31 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome