Hard start 300d with only 208K - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 02-25-2010, 12:15 PM Thread Starter
BenzWorld Junior Member
87300d's Avatar
Date registered: Feb 2010
Posts: 41
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
Hard start 300d with only 208K

This is the second time this has happend in about 6 months. Went to start my Daily driver 87 300D. Crank crank and crank nothing. Drained battery, charged it then it started only with the pedal to the metal. Engine heater was plugged in, glow plugs are fine. What going on?
I was thinking injectors?
Also every now and then I will add some 2 stoke oil mix to the tank, just a little of Golden Spectro mix, it runs nice and quiet when I do so. Will this hurt?
87300d is offline  
Sponsored Links
post #2 of 2 (permalink) Old 02-25-2010, 11:58 PM
BenzWorld Elite
Govert70227's Avatar
Date registered: Oct 2009
Vehicle: 2000 VW Golf Variant
Location: Leiden, Netherlands
Posts: 2,952
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
I think you have more success with your question in the W124 forum.

Your car is designed to run on diesel, not on two-stroke oil. Quieter running doesn't necessarely mean better running.
Govert70227 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    82 300d HARD/WILL NOT start homeboyjohn_96 W123 E,CE,D,CD,TD,TE Class 11 01-22-2010 07:01 AM
    0w-40 no longer avaliable anywhere I look... recommended weights? Midwest, 208K miles HACK THT W163 M-Class 32 10-26-2009 07:38 PM
    300D hard to start when cold Greg A. W124 E,CE,D,TD Class 9 03-14-2007 05:51 AM
    300D hard start saga... Advice? DieselDave W123 E,CE,D,CD,TD,TE Class 3 01-12-2005 05:27 AM
    Hard start or second start when warm high hc level-- beware major expense Peter Seow W126 S,SE,SEC,SEL,SD,SDL Class 1 07-03-2004 06:23 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome