Replace starter cable 1968 200D - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 08-17-2009, 08:49 PM Thread Starter
BenzWorld Newbie
Date registered: Aug 2009
Vehicle: 1968 MB 200D Manual
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Post Replace starter cable 1968 200D

Hi, had a cable break on me. Any know how to pull the starter lever out of the dash, I can't seem to find any access to this.

Thank for your help!
drettig is offline  
Sponsored Links
post #2 of 3 (permalink) Old 08-24-2009, 02:03 PM
BenzWorld Senior Member
Date registered: Jun 2004
Posts: 497
Mentioned: 0 Post(s)
Quoted: 17 Post(s)
Is that a W110 or a W114/115? Either one should be the same process. You need to remove the complete switch unit. First, unscrew the knob. Second, unscrew the chrome nut/bolt/bezel under the knob. There probably is a special tool for getting the nut off without buggering up the nut, but I haven't seen one. After the nut is off, you can push the unit back and remove it from below. Then you can take the cable off.

If I remember right, there is a small cable going from the key switch to the starter switch for some kind of interlock mechanism. It can be easily detached from the key switch or starter switch, can't remember from which though.
KCM is offline  
post #3 of 3 (permalink) Old 08-31-2009, 04:18 PM
BenzWorld Newbie
Date registered: Jul 2009
Vehicle: 1974 Mercedes-Benz 240D
Location: Beaverdale, Des Moines, IOWA
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via Yahoo to NixonSinatra
I think I had this same thing happen, though not sure if the cable broke, or simply the piece (?) which secures in into the dash. Pulled out fine upon startup (or so I thought), however, when I went to push it back in to shut the car down, it would not correctly push back in. I couldn't figure out how the heck I was going to get the car to shut off? Finally, in a fit or rage (panic) I hit in good and hard and the car finally shut off.

Does that sound similar? I wonder if this too could be a broken cable, or some other piece of the pull starter?
NixonSinatra is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    how to replace a starter on a ml430 KAYLASML W163 M-Class 4 05-13-2015 07:42 PM
    Battery to starter cable bluecollarpilot R/C107 SL/SLC Class 7 02-08-2008 11:05 AM
    Anyone ever replace a starter? SpeedDemon R129 SL-Class 15 01-30-2007 07:51 AM
    Alternator/Starter/Battery cable issue Gvigorus W123 E,CE,D,CD,TD,TE Class 26 11-10-2005 01:21 AM
    replace starter on 560 SL Guest (MBNZ) General Mercedes-Benz 0 02-24-2002 04:03 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome