Connection problem of w109 6.3 tachometer in w108 280SE 4.5 - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-25-2009, 04:11 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Jun 2009
Vehicle: 280SE 3.5
Location: Istanbul/Turkey
Posts: 25
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Connection problem of w109 6.3 tachometer in w108 280SE 4.5

Hi everybody,

I just registered to this forum in order to find out solution and share problems of my classic mercedes.Recently I'm dealing with placing vintage VDO tachometer which was used in 300SEL 6.3 to my 1972 280SE 4.5 with electronic ignition.

Few months ago,I bought 6.3 tachometer and last week placed to my car by taking out clock from cluster housing.I connected 12V Power voltage and ground connections.But I have problems with pulse connection.I connected pulse to a cable which is green with yellow lines come from electronic box to terminal.However, on idle it works normal but during accelaration after 2000 rpm it falls down to zero(like it does not work) then when I pull off pedal it jumps again and shows.

According to my opinion as 300SEL 6.3 has standard ignition, pulse is directly got from (-) pole of coil, when I connected to my transistorized ignition due to pulse differences tacho does not read.

Please help for instruction to connect this tachometer to transistorized ignition?Because I saw picture that 6.3 tacho was on 300SEL 3.5 which is also electronic ignition.

Regards,

Kutluhan

Last edited by Jazzenco; 06-25-2009 at 04:14 PM.
Jazzenco is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 09-24-2009, 01:13 PM
BenzWorld Member
 
Peoria Benz's Avatar
 
Date registered: Jul 2006
Posts: 93
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I came across a 6.3 tach and tested it and found I was getting too high of a reading at idle and the needle would flutter from 0 to its limit when the revs increased. Anyone know anything about all of this?
Peoria Benz is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    W108 / W109 Bumper For Sale alabbasi Vintage Mercedes-Benz 0 05-21-2009 10:53 AM
    WTB: Wheels from W108, W109 or W113 mangrum For Sale/Wanted/Trade/Giveaway 4 05-21-2009 06:12 AM
    I'm in love with the w108/w109 janos_z W126 S,SE,SEC,SEL,SD,SDL Class 12 11-21-2008 10:00 AM
    W108 / W109 Aircon sklas Vintage Mercedes-Benz 11 03-07-2008 10:12 PM
    1972 W108 280SE 3.5 Distributor setting problem Guest (MBNZ) General Mercedes-Benz 2 02-15-2001 04:26 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome