1976 450 sel cranks but won't start... - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 06-22-2009, 07:49 AM Thread Starter
BenzWorld Newbie
Date registered: Jun 2009
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1976 450 sel cranks but won't start...

Have a 76' 450sel. cranks but doesn't turn over. I shoot some carb cleaner down the intake and then it turns over then dies once all the carb cleaner is burned through. Car sat for a few years. When it was last started it started right up.

fuel pump gone bad? i can't hear the pump when cranking the engine.

any other ideas?

please help
JanR is offline  
Sponsored Links
post #2 of 4 (permalink) Old 06-24-2009, 07:43 AM
BenzWorld Veteran
Date registered: Apr 2009
Vehicle: Current: 1987 560 SEC US, former factory trained MB tech 10 years, owner of 14 others.
Location: Spokane, WA.
Posts: 723
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Well, do the dynamic duo, spark and fuel. Take out a plug, and see if it sparks. Next, get a rag and remove the cold start injector line at the injector. Crank, and look for fuel. If not, chane out relay, if no fuel still, chan out pump.

You can also just do a voltage test at the fuel pump terminals, that is easiest. If power is to it when cranking , bad pump.
renaissance_warrior is offline  
post #3 of 4 (permalink) Old 06-24-2009, 06:46 PM
BenzWorld Junior Member
Date registered: Sep 2008
Location: Prince George, Canada
Posts: 47
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
it could be bad gas, although it should still start, and just not run great.

I've been told that the lifespan of gas is only supposed to be 3 to 4 months, probably 6 at best. At the same time though my merc had been sitting for 2 years and the gas was still ok, not great though, but enough to have it running.
ebouwman is offline  
post #4 of 4 (permalink) Old 06-30-2009, 09:48 AM
BenzWorld Elite
Ed Mclass's Avatar
Date registered: Aug 2002
Vehicle: 90 300 SE ,85 300 GD
Location: Bell Buckle, Tennessee
Posts: 1,574
Mentioned: 0 Post(s)
Quoted: 1 Post(s)

Open up the fusebox and replace EVERY ceramic fuse with a new one. See if that improves your starting.
Ed Mclass is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    1976 450 sl exhaust homecooking R/C107 SL/SLC Class 4 04-06-2009 11:45 AM
    1976 450 SL boxofcheez W116 S, SE, SEL, SD Class 2 04-06-2009 08:55 AM
    No start-Hard start, multiple cranks, Help??? gquarrick W210 E-Class 13 11-24-2008 03:16 PM
    1976 450 sl won't run...... squirrel_master R/C107 SL/SLC Class 2 09-24-2006 09:32 PM
    I just inherited a Mint condition 1976 450 SEL !!! Guest (MBNZ) W126 S,SE,SEC,SEL,SD,SDL Class 3 06-24-2002 05:18 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome