1981 380sl a/c problem-plz help - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-08-2009, 07:55 PM Thread Starter
BenzWorld Newbie
Date registered: Jun 2009
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1981 380sl a/c problem-plz help

I replaced my a/c condenser and put in 3 cans of 134a and a can of 134a leak detector and sealer. When I put in the 134a into the low intake side I did not feel any cold in the tubing. The compressor comes on and turns and the cluth pulls in but no air (hot or cold) comes out of the dash vents. The defroster blows. Does anyone have any ideas? Do I have an orifice tube with a filter in it? Could this be the problem? Checked all fuses. Thank you
centextrader is offline  
Sponsored Links
post #2 of 2 (permalink) Old 06-08-2009, 08:17 PM
BenzWorld Veteran
Date registered: Apr 2009
Vehicle: Current: 1987 560 SEC US, former factory trained MB tech 10 years, owner of 14 others.
Location: Spokane, WA.
Posts: 723
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
You really should have the system evacuated and it will take 134 a lot better. It sounds like a dirty orifice tube, and it is a filter as well.
renaissance_warrior is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Need 1981 380SL help please... surveyor General Mercedes-Benz 3 01-13-2009 05:51 PM
    cabriolet problem top wont go do.....plz plz read!! xenergiser2004x C208/A208 CLK-Class 1 05-27-2008 12:17 PM
    1981 380SL Idle Problem xccman R/C107 SL/SLC Class 6 01-26-2005 04:01 PM
    1981 380SL serick9 R/C107 SL/SLC Class 4 01-27-2004 10:41 AM
    1981 380SL Vents Guest (MBNZ) R/C107 SL/SLC Class 1 01-07-2002 06:43 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome