Injection Pump Problems?? - Page 3 - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #21 of 22 (permalink) Old 06-13-2009, 04:42 PM
BenzWorld Junior Member
 
Date registered: Jun 2009
Posts: 11
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Did you get my reply to the Cherry Bomb idea? I sent it but I see its not posted here.
kevbobev is offline  
Sponsored Links
Advertisement
 
post #22 of 22 (permalink) Old 06-15-2009, 05:32 AM Thread Starter
BenzWorld Junior Member
 
robgigliotti's Avatar
 
Date registered: Feb 2009
Posts: 41
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
I did not get the cherry bomb idea. I had that thought though, take out the resonator and put a cherry bomb in there, cheeper and easier I think. After the vacuum diaphram change and the little part on the front of the pump; which still held vacuum when I opened it. I dont think it did anything for the performance. I think that I am going to have to come to terms that this car isnt supposed to go fast, its 40 years old and its not a hill climber. I also did another can of diesel purge, and the same result. The fuel that was coming from the return was almost pink. weird? Didnt come out black like my 300sd did, I mean black. I think that is from the corn oil that I put in it last year.

I am suspect that the injection pump was changed on my car, you know how you buy something at a junkyard and there are some yellow paint stick markings on it; I see a bolt on this pump that has a dab of yellow paint on it. Nothing on the pump, just a bolt. Makes me wonder. The people that I got the car from know nothing about it, the guy that owned it has been dead for a while, he aint answering any questions. How would I know if the pump was out of wack? It still smokes, not like a chimney but it smokes. Someone told me that the smoke smells like unburnt fuel? Should I just live with the cards taht are dealt to me and be jealous of everyone that says they can get 80 mph out of their rod? Ohh the little green car...

______________________________
1984 300sd -
1969 220d -
1997 Chevy Suburban -
robgigliotti is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
swaping a 85 motor into my 84 300d, injection pump problems.. Mtouring554 W123 E,CE,D,CD,TD,TE Class 1 05-21-2009 11:06 PM
Looking for 1980 300D Lift Pump and Injection Pump internal diagrams kiannone W123 E,CE,D,CD,TD,TE Class 8 02-16-2009 11:47 AM
Injection Pump Problems Jon L W201 190-Class 3 02-05-2009 02:02 PM
Problems with checking injection pump timing ROLLGUY W201 190-Class 0 08-06-2007 05:37 PM
Injection Pump P-Rex85 W123 E,CE,D,CD,TD,TE Class 0 08-04-2006 10:18 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome