Merc W114 Trouble - Page 2 - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #11 of 14 (permalink) Old 04-11-2009, 07:14 AM
BenzWorld Elite
 
Grubeguy's Avatar
 
Date registered: Jan 2006
Vehicle: 73 280SE 4.5, 71 300SEL, 03 BMW Z4, 72 Fiat 850, 80 Triumph TR7, 85 Porsche 911
Location: DC Area
Posts: 2,111
Mentioned: 1 Post(s)
Quoted: 96 Post(s)
Send a message via MSN to Grubeguy Send a message via Yahoo to Grubeguy
The dial on the ECU controls fuel/air mixture...
Grubeguy is offline  
Sponsored Links
Advertisement
 
post #12 of 14 (permalink) Old 04-12-2009, 12:00 PM
BenzWorld Junior Member
 
bobtherebuilder's Avatar
 
Date registered: Apr 2008
Vehicle: W114 280CE W124 200TE
Location: Dublin Ireland
Posts: 20
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Clockwise to give richer mix,anti clockwise weakens.
bobtherebuilder is offline  
post #13 of 14 (permalink) Old 04-16-2009, 09:19 PM
BenzWorld Newbie
 
Date registered: Apr 2009
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Nice post. I am learning alot through people's reply. I am trying to learn about cars and parts and how each parts works. Atleast if i get my own car and if died or have trouble i can do something to fixed it. Thanks
Eden John is offline  
post #14 of 14 (permalink) Old 08-15-2010, 10:36 PM
BenzWorld Junior Member
 
Master09's Avatar
 
Date registered: Aug 2010
Vehicle: 1975 Mercedes 280E W114
Location: Australia
Posts: 18
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by drew56cus View Post
mbbuff, I have to rebuff you (pardon the pun) - Australia got w114 cars with the M110 motor, both fuel injected (280E) and carbied (280).
Joelll, sorry I cannot add much more as I had the mis-pleasure of trying to get an M110 going in a W123 and it was a bugger. Vacuum lines, lots of sensors, many things associated with the injection and ignition that can go wrong and are in horrible places to get to. Hopefully Mercmad6.3 will post a response as he got the M110 going for me.
Cheers, Drew in Brisbane
Ahem.
Please observe gentlemen, the picture below. My W114 280E. M110 D-jetronic.




Another thing, where is the ECU dial??? My fuel is running way too rich...

Last edited by Master09; 08-15-2010 at 10:39 PM.
Master09 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    My W114 feerocknok Vintage Mercedes-Benz 3 01-10-2009 11:12 AM
    w114 lilbilly11 Vintage Mercedes-Benz 2 12-19-2007 05:54 PM
    Merc w114/5 Sills info needed! ScrapingScrap Vintage Mercedes-Benz 2 10-31-2005 01:16 PM
    People buy Merc. for 1 pound-race 4500 miles across desert-give said Merc. away for free? ilikemercedes W123 E,CE,D,CD,TD,TE Class 2 12-24-2004 06:13 AM
    W114 MB250 Vintage Mercedes-Benz 5 08-03-2004 01:49 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome