72 280sel - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 10-25-2008, 12:33 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Oct 2008
Vehicle: 280sel
Location: watsonville/salinas
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
72 280sel

i just changed my fuel pump and checked the filter and its all ok and im still not getting any fuel pressure ?????
what do i do?
mprider is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 10-25-2008, 01:24 PM
BenzWorld Elite
 
Grubeguy's Avatar
 
Date registered: Jan 2006
Vehicle: 73 280SE 4.5, 71 300SEL, 03 BMW Z4, 72 Fiat 850, 80 Triumph TR7, 85 Porsche 911
Location: DC Area
Posts: 2,110
Mentioned: 1 Post(s)
Quoted: 95 Post(s)
Send a message via MSN to Grubeguy Send a message via Yahoo to Grubeguy
Is your pump getting voltage? When you first turn the key on, do you hear the pump run for a second or two? If not, check the relay, the fuse and of course, wiring.
Grubeguy is offline  
post #3 of 10 (permalink) Old 10-25-2008, 05:31 PM
BenzWorld Elite
 
wbain's Avatar
 
Date registered: Dec 2003
Vehicle: 1965 220S, 1999 Volvo V70 (wagon), 2006 Ford Crown Vic Police Interceptor, 72 350SL 4 Speed
Location: Near Manassas Va.
Posts: 1,830
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
6 cyl or V-8? In other words, mechanical FI or EFI?

Near Manassas Va. '65 220S, 2006 Ford Crown Victoria Police Interceptor, '99 Volvo V70, '72 350SL 4 speed

Not part of the in-crowd since 1952. It's BRAKES not breaks. You break a bone, use brakes to stop your car. /rant

http://www.megamanual.com/index.html
http://www.bgsoflex.com/megasquirt.html
wbain is offline  
post #4 of 10 (permalink) Old 10-25-2008, 09:32 PM
Lifetime Premium Member
 
Date registered: Dec 2004
Vehicle: 1972 280CE
Location: Dallas, TX
Posts: 3,888
Mentioned: 1 Post(s)
Quoted: 108 Post(s)
Lifetime Premium Member
First thing first, check if the fuel pump is running. If not then it's electrical. You can take a battery booster and jump the pump.

If the pump is running. Then you probably have a blockage in the tank. Remove the fuel line to the pump and see if there is any fuel coming out.

With best regards

Al

Check out the W114, W115 /8 enthusiast forum http://www.stroke8.org

My 280SL restoration
alabbasi is offline  
post #5 of 10 (permalink) Old 10-26-2008, 05:29 AM
BenzWorld Veteran
 
Date registered: Jun 2004
Posts: 700
Mentioned: 1 Post(s)
Quoted: 5 Post(s)
Quote:
Originally Posted by mprider View Post
i just changed my fuel pump and checked the filter and its all ok and im still not getting any fuel pressure ?????
what do i do?
280SEL. It's a six clyinder MFI equipped W109 with steel springs.
The tank has a fuel filter in the drain bung . There is also a filter and ball valve in the pump it'self.
mercmad6.3 is offline  
post #6 of 10 (permalink) Old 10-26-2008, 02:20 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Oct 2008
Vehicle: 280sel
Location: watsonville/salinas
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
its a v8 and the pump turns on once i turn the key
mprider is offline  
post #7 of 10 (permalink) Old 10-26-2008, 02:42 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Oct 2008
Vehicle: 280sel
Location: watsonville/salinas
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
what would i have to do if there was a blockage in the tank??
mprider is offline  
post #8 of 10 (permalink) Old 10-27-2008, 01:03 AM
BenzWorld Elite
 
wbain's Avatar
 
Date registered: Dec 2003
Vehicle: 1965 220S, 1999 Volvo V70 (wagon), 2006 Ford Crown Vic Police Interceptor, 72 350SL 4 Speed
Location: Near Manassas Va.
Posts: 1,830
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Quote:
Originally Posted by mercmad6.3 View Post
280SEL. It's a six clyinder MFI equipped W109 with steel springs.
The tank has a fuel filter in the drain bung . There is also a filter and ball valve in the pump it'self.

That would be a W108. It's a 280SEL 4.5.

As for the fuel flow, the tank cab be checked from the trunk. The fuel level sensor bolts on top of the tank and is covered by a plastic cap on the trunk floor. Look insode, the pickup could be blocked.

Near Manassas Va. '65 220S, 2006 Ford Crown Victoria Police Interceptor, '99 Volvo V70, '72 350SL 4 speed

Not part of the in-crowd since 1952. It's BRAKES not breaks. You break a bone, use brakes to stop your car. /rant

http://www.megamanual.com/index.html
http://www.bgsoflex.com/megasquirt.html
wbain is offline  
post #9 of 10 (permalink) Old 10-27-2008, 10:45 AM
BenzWorld Elite
 
Grubeguy's Avatar
 
Date registered: Jan 2006
Vehicle: 73 280SE 4.5, 71 300SEL, 03 BMW Z4, 72 Fiat 850, 80 Triumph TR7, 85 Porsche 911
Location: DC Area
Posts: 2,110
Mentioned: 1 Post(s)
Quoted: 95 Post(s)
Send a message via MSN to Grubeguy Send a message via Yahoo to Grubeguy
I agree - inside the tank is a wire mesh screen that might be clogged. If the pump runs, and it's a new pump, it sounds like you have a blockage in the lines or in the tank.
Grubeguy is offline  
post #10 of 10 (permalink) Old 11-02-2008, 12:17 PM
BenzWorld Senior Member
 
Date registered: May 2007
Vehicle: 64' 220SEc, 72' 300SEL 6.3, lots of parts
Location: San Diego/Spring Valley
Posts: 512
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Remove and clean tank, then replace ALL rubber hoses, clean and purge the remaining system.

Brian O
bostosh is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Anyone else with 81-85 280sel ? RevJD W126 S,SE,SEC,SEL,SD,SDL Class 22 03-31-2009 12:26 AM
    280SEL Hemersam W126 S,SE,SEC,SEL,SD,SDL Class 3 08-30-2007 12:21 PM
    '85 280SEL Hemersam For Sale/Wanted/Trade/Giveaway 1 08-29-2007 08:53 PM
    1973 280SEL 4.5 MBZ300CD Vintage Mercedes-Benz 13 09-03-2006 02:18 PM
    280SEL? BILLSONG W116 S, SE, SEL, SD Class 1 10-28-2005 05:38 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome