1976 450 sl 107 body 117 engine camshaft problems need advice fast - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 09-25-2008, 03:49 AM Thread Starter
BenzWorld Newbie
Date registered: Sep 2008
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Exclamation 1976 450 sl 107 body 117 engine camshaft problems need advice fast

i am in the middle of buying a 1976 450 sl with 117 v8 engine . 180000 miles it has good oil pressure

the guy said it ran and drove good and just needed the battery charged and that it had been sitting for a while.

after paying for most of it we took last weekend to get it fired up charged the battery drained the gas tank cleaned all the filters fuel pump and a new battery.

we got it fired up and the engine knocks it is coming from the passenger side valve cover. then the guys buddy stops buy that the guy i am buying it from who used to be a mechanic, and said the cam needed to be replaced and that one cam lobe was wore. he then then told me how this came to be. he told me the lifter failed and would not allow the follower to travel hence wearing the lobe off.

my question is, is this right? or is it more likely that the valve stuck or bent and the head needs work.

if it is just a cam, lifter and follower does any one know where i can get used part resonable?

Last edited by oneoldhounddog; 09-25-2008 at 03:52 AM. Reason: parts inquire
oneoldhounddog is offline  
Sponsored Links
post #2 of 4 (permalink) Old 09-25-2008, 04:07 AM
BenzWorld Veteran
Date registered: Jun 2004
Posts: 700
Mentioned: 1 Post(s)
Quoted: 5 Post(s)
REmove the cam cover,it has four boltas holding it down. Look at each cam lobe ,you will soon see the worn lobe. there is no follower or lifter like a chevy ,just a rocker arm which works the valve. there is a adjustable pivot,often cqalled a tappet. Just buy a good used cam and rockers . make sure each rocker arm is matched to each lobe and don't mix them up because they will wear really fast and you will be back where you started. Replace the cam and make sure you don't mix the cam timing up and you will be OK. Replace the tube on the top of the cam,thats the oiler for the cam and is usually the main reason cam lobes wear when it gets blocked.
mercmad6.3 is offline  
post #3 of 4 (permalink) Old 09-25-2008, 04:33 AM Thread Starter
BenzWorld Newbie
Date registered: Sep 2008
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
thanks for the advice

thank you for the advice and the speed of your answer. i have been doing some work on the guys home i am getting the car from and he is turning into quite the jew so i am losing my trust in him so i thought i better get some answers before i decided to close the deal on this car

once again thank you

oneoldhounddog is offline  
post #4 of 4 (permalink) Old 09-26-2008, 09:00 AM
BenzWorld Senior Member
Date registered: May 2007
Vehicle: 64' 220SEc, 72' 300SEL 6.3, lots of parts
Location: San Diego/Spring Valley
Posts: 512
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
run from it

If you observe a worn lobe,
ask yourself where the metal went.
chances are into the entire oil system,
bearings, for instance, ( fatal problem).

I am doing a rebuild - ring/valve on a M117
and am up to $1200 just for parts.

If the body and interior are "perfect" and car is cheap
it is worth the cost of a new motor? 5k-6k

At that mileage a rebuilt transmission is in the near future 2.5k

I do have a spare long block for that car.

Brian O
bostosh is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    1976 450 SL boxofcheez W116 S, SE, SEL, SD Class 2 04-06-2009 08:55 AM
    1976 450 sl 107 body 117 engine oneoldhounddog General Mercedes-Benz 0 09-25-2008 03:36 AM
    1976 450 sl won't run...... squirrel_master R/C107 SL/SLC Class 2 09-24-2006 09:32 PM
    FS: 1984 Mercedes-Benz 500SL (body 107, engine 117) bphunter1972 For Sale/Wanted/Trade/Giveaway 7 09-13-2005 10:52 AM
    My new baby should be here next weekend /107 slc 1976 Gordon Foster R/C107 SL/SLC Class 0 08-30-2003 08:36 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome