240D high idle - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-11-2008, 11:05 PM Thread Starter
BenzWorld Junior Member
Date registered: Jun 2008
Posts: 30
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
240D high idle

I am still working on the kinks my 1975 240D has. The biggest problem left is a high idle. It is managable, but still annoying. It is not very bad when the engine is cold, but it is very noticable once it warms up (gotta keep a little pressure on the brake when stopped to keep it from going). I checked out the little idle adjust knob, and it is set fine. The throttle linkage all seems fine as far as I can tell. The linkage to the injection pump seems to be all the way down with the accelerator not pressed. So what else could this be? I have not yet adjusted the valves or injection pump timing nor have I replaced the fuel filters yet. Could it also be some adjustment needed for the air intake?
bagawk is offline  
Sponsored Links
post #2 of 3 (permalink) Old 06-13-2008, 11:38 PM Thread Starter
BenzWorld Junior Member
Date registered: Jun 2008
Posts: 30
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Anyone have any ideas or possible troubleshooting suggestions? Does the injection pump have any adjustments? The car also has a fair amount of blowby gases. Could this cause some of the problem? Could that be helped with a valve adjustment?

Anything would be great!

Last edited by bagawk; 06-13-2008 at 11:45 PM.
bagawk is offline  
post #3 of 3 (permalink) Old 09-29-2009, 11:07 AM
BenzWorld Junior Member
Keevo114's Avatar
Date registered: Jun 2008
Posts: 17
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Try leaking out some OIL could be bruning the engine OIL instead of the pump. also try pushing the fuel cut off lever in a little see if it drops some. if so, there is also an adjustment on the back of the IP, but before you do that make sure the lines coming from the intake flap, going to the governor, is not leaking, Mine does the same if i disconnect it. If it's not leaking then remove the governor , and check the diaphram and spring inside for any holes or damage. be carefull its made of Leather, also the diaphrams rod connecting to the IP internal fuel rail is held by a saftey pin, you need to be very carefull use a magnet below it and a pair of small needle nose pliers to remove it, then the houseing should come off. Once out. you can clean the diaphram with a rag, don't use any chemicals or WD 40 or anything liek that here. And. once the you have checked the spring inside the throttle lever. clean that with diesel and dry with non-lent producing ragg. NOT shop towels or paper towels. If the gasket broke when taking apart do you best to either replace it, OR make one from gasket material. DO not use any silicone around here, it will fall off inside and get into the pump and destroy it. also be very carefull not to allow any debris get into the openings. If you still have problems. you can take it off again, and remove the rear support for the IP to the block, then you can access the 19mm nut and flat head locking screw. I belive out allows more fuel, but this is usually for top exccel fuel delivery, so if you back it out you may get more smoke, but more power.
Keevo114 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Testing Idle Valve - High Idle Problem Jonathan Laws W126 S,SE,SEC,SEL,SD,SDL Class 16 08-11-2012 05:55 AM
    High neutral idle + once in gear way rough idle Rickysa R/C107 SL/SLC Class 3 04-12-2008 12:50 PM
    Help! Normal idle when Cold/ High idle when Hot VicsBenz W201 190-Class 20 03-23-2007 08:58 PM
    Rough idle Vs high idle NewMBie W126 S,SE,SEC,SEL,SD,SDL Class 3 12-29-2004 09:17 PM
    High Idle Again. Big D W126 S,SE,SEC,SEL,SD,SDL Class 6 06-12-2004 01:49 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome