1979 W107 450SL with no heat...questions... - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-24-2007, 07:58 AM Thread Starter
BenzWorld Junior Member
Date registered: Jun 2007
Posts: 8
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1979 W107 450SL with no heat...questions...

Hi, fellas and gals: Daisy, our SL, has no heat. Everything else is fine - all A/C operations work correctly. The Aux Water Pump works (I powerred it up with a separate 12V source). SO....Either it might be the Climate Control Amp, ormaybe there's a little switch/solenoid in the chain that's open and not energizing? I also have one of George Murphy's great rebuilt Servos, but am keeping it in reserve as the original one doesn't leak and seems to be okay.

Can someone give me some hints on where to diagnose this further?

Better to e-mail be direct at ac1y@nc.rr.com


Sandy Gerli is offline  
Sponsored Links
post #2 of 3 (permalink) Old 10-24-2007, 08:45 AM
Administratoris Emeritus
GeeS's Avatar
Date registered: Aug 2002
Vehicle: 2021 SL770
Location: Fountain Hills, AZ
Posts: 44,831
Mentioned: 1 Post(s)
Quoted: 544 Post(s)
Welcome to BenzWorld Sandy! Check to see if you can get heat on your Defrost setting, If you do, that is a classic symptom of a failed ACC Amplifier. If you cannot get head on Defrost, you may be looking at a dreaded ACC Servo failure.

"If spending money you don't have is the height of stupidity, borrowing money to give it away is the height of insanity." -- anon
GeeS is offline  
post #3 of 3 (permalink) Old 10-25-2007, 06:04 AM
BenzWorld Elite
flyboyike's Avatar
Date registered: May 2003
Vehicle: 2012 Focus SE
Location: Ormond Beach, FL
Posts: 7,697
Mentioned: 1 Post(s)
Quoted: 67 Post(s)
I agree with what Ron said. One quick check is to see if the coolant lines coming OUT of the heater core are hot.

Felicita e un bicchiere di vino con un panino.
flyboyike is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Mb 280slc 1979 W107 agentk R/C107 SL/SLC Class 14 06-11-2007 05:44 AM
    1979 450sl Power Steering Questions houston14 R/C107 SL/SLC Class 1 02-03-2007 02:34 PM
    Heat coming from steering coloumn... W107 tubbee R/C107 SL/SLC Class 5 06-25-2006 05:25 PM
    Tires for 1979 450SL johnregnery R/C107 SL/SLC Class 5 12-06-2004 07:15 PM
    year 1979- W107- inline six how worth? burak sozer R/C107 SL/SLC Class 0 11-01-2002 07:06 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome