wipers acting up - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 07-28-2007, 04:42 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Jul 2007
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
wipers acting up

I HAVE A 1969 280S W108 AND THE WIPERS WONT RETURN TO THERE CORRECT POSITION,THEY ARE NEARLY VERTICAL ON THE WINDSHIELD.TO MAKE MATTERS WORSE I GOT CAUGHT IN A STORM ON THE MOTORWAY AND HEARD A NOISE UNDER THE DASH AND THE WIPERS STOPPED WORKING,WHEN I GOT HOME I TOOK THE GLOVE BOX OUT AND ONE OF THE WIPER ARMS HAD SNAPPED.HAS ANYONE ANY ADVICE ON HOW TO REMOVE THE DASH TO FIX ARMS.HAS THIS HAPPENED TO ANYONE,ALL ADVICE WELCOME.
PACMAN is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 07-30-2007, 08:08 AM
BenzWorld Junior Member
 
Date registered: Jun 2007
Vehicle: 1972 250
Location: maryland
Posts: 10
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via AIM to kayvon
this has happend to me on my w114, i just had to take off the covers under the dash and i could see the mechanics of the wipers, just take a look at them --the linkage from the driverside(where the motor is) to the other side probably came apart(made the sound). then you might just have to tighten some bolt and adjust it so they stop at the bottom.
kayvon is offline  
post #3 of 3 (permalink) Old 07-30-2007, 11:06 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Jul 2007
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
THANKS HAD A LOOK AT IT YESTERDAY THE LINKAGE SNAPPED BEHIND THE GLOVE BOX ,HAD TO GET THE HEATER OUT OF THE WAY AND THEN I WELDED IT BACK TOGETHER.THE END OF THE WIPER MOTORS ARE SPLINED AND THE LINKAGE BAR THAT IS CONNECTED TO IT IS SPLINED ALSO,THIS BAR HAD LOST ALL ITS TEETH SO IT WAS IMPOSSIBLE TO TIGHTEN IT IN THE RIGHT POSITION.I LOOKED FOR A NEW ONE ON THE INTERNET BUT FOUND OUT THAT YOU HAD TO BUY THE WIPER MOTOR AS ONE UNIT.LUCKY ENOUGH A NEIGHBOR HAD SCRAPPED A 108 YEARS AGO AND HE KEPT THE WIPER LINKAGE.JOBS A GOOD UN.

Last edited by PACMAN; 07-30-2007 at 04:09 PM.
PACMAN is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    I think my MAF is acting up - yet again. ponch W203 C-Class 3 11-20-2006 10:18 AM
    the 2.6 is acting up..... AMSOIL300CDT W201 190-Class 4 04-20-2006 10:25 PM
    blinkers acting up...need help SLICKSLK007 C208/A208 CLK-Class 1 10-20-2005 09:53 PM
    Radio acting up Boxster Boy R170 SLK-Class 2 09-16-2002 09:01 AM
    Radio - Acting up BlackDog R170 SLK-Class 0 05-03-2002 07:27 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome