Fixing the dashboard lighting - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-17-2007, 09:41 AM Thread Starter
BenzWorld Member
 
Date registered: Jun 2007
Vehicle: Mercedes-Benz W114 280CE '73
Location: Budapest, Hungary and Farmington Hills, MI
Posts: 63
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via MSN to ICram
(Thread Starter)
Fixing the dashboard lighting

Hi!

I have an '73 European 280CE and my dashboard lighting isnt working. I have checked the fusebox but every fuse is ok. Im planning to take out the dashboard and check the wiring contacts but i dont know how to take out the dashboard and what to check behind it.

Thanks in advance.

Edit: The interior lighting and the auto trans lighting are oks but the tachometer's and the other units lighting and even the frontlight switcher arent ligihting.

Last edited by ICram; 06-17-2007 at 09:45 AM.
ICram is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-17-2007, 06:22 PM
BenzWorld Senior Member
 
Date registered: Jun 2006
Vehicle: 1981 300CD, 1973 280C
Location: California
Posts: 448
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
The reostat to illuminate and dim the dash lights is next to the tripmeter. Sometimes gently rotating it will restore illumination. Most times tho the reostat is worn out. If the gauge cluster is like my 280 SEL was, you remove the parking brake bracket under the dash to let the pull handle drop down. Then with a small hand reach up to unscrew the knurled nut holding the cross piece holding the cluster in. This nut is centered behind the clock. then pull the cross piece straight back and out. Then disconnect speedo cable. Pull the cluster toward the steering wheel, reach behind pull off the multi wire connector and remove entire cluster. You will see the reostat secured to the printed circuit. I soldered a short piece of wire across the two reostat posts so the illumination was permanent full bright. You might get lucky and the cross piece is no longer there! if thats the case just removing the speedo cable and electrical connector will allow cluster removal. On the headlight switch, the orange light will only illuminate with fog lights on after the switch is pulled straight out. Most do not illuminate as a rule because they are not equipped with a rear fog bulb nor socket.
carnut1 is offline  
post #3 of 3 (permalink) Old 06-17-2007, 07:27 PM Thread Starter
BenzWorld Member
 
Date registered: Jun 2007
Vehicle: Mercedes-Benz W114 280CE '73
Location: Budapest, Hungary and Farmington Hills, MI
Posts: 63
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via MSN to ICram
(Thread Starter)
Thanks mate.

I have fixed it. The lighting power changer's copper "wire" was oxidated. So i cleaned it and now its ok. Works perfectly

The fog light indicator light still not working I have integrated fog lights. The bulb is in perfect condition. So i dont know why it isnt working
ICram is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Dashboard Lighting manymercsmike W126 S,SE,SEC,SEL,SD,SDL Class 4 03-16-2007 05:33 AM
    dashboard lighting question en-em W163 M-Class 0 08-08-2005 05:49 PM
    Need suggestions on fixing cracks in dashboard jtoma878 W123 E,CE,D,CD,TD,TE Class 15 02-11-2005 11:22 AM
    Dashboard lighting DrBenz W201 190-Class 10 10-12-2004 06:04 AM
    Help with fixing instrument panel lighting: Darkmann W163 M-Class 4 03-22-2003 01:40 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome