Need Help - New problem - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 05-04-2007, 06:36 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Oct 2006
Vehicle: 1973 MB 280
Location: Oakville, Canada
Posts: 23
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Need Help - New problem -Blown Gasket

Hello
My car has developed a new problem. I have been driving it for about 6 months now, and yesterday I noticed smoke coming out of exhaust. It was while driving on the Hwy traffic had come to a standstill so after the stop when traffic strted to move I looked in the rear view mirror a noticed some smoke behind my car. I was surprised at first because it was first time I seen it smoke .
Now I kept on watching my rearview mirror to see if more smoke was coming out but no, it was ok. Again I stopped at a traffis light at the exit and there was no smoke but when I started to move there was a big plume of smoke again.
And the same thing happned this morning too while coming to work.

I heed help, please, can someone tell me what is going on, what should I do?

Thanks
Kardar

UPDATE

Ok the mechanic diagnosed that the head gasket is leaking, he took the Spark plug out and it was wet & sort of greenish color. He thinks that coolant is getting in through the blown gasket. to replace thagsket, may be also machine the head, he has quoted me $1600 dollars (Canadian). I am not sure if this is the best option, a friend had suggested a rebuilt engine. How much does a rebuild engine cost and where can I buy one. Or if it is advised to go for repairs what else should or can I get done while the head is off.
Thanks
Kardar

Last edited by kardar; 05-07-2007 at 07:58 PM.
kardar is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 05-04-2007, 02:53 PM
BenzWorld Senior Member
 
Date registered: Jun 2006
Vehicle: 1981 300CD, 1973 280C
Location: California
Posts: 448
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
If the automatic trans is overfilled it would smoke because the excess vents onto the hot exhaust. After 30 min. of driving, check the fluid level, car idling in park. Should be just below the full mark. Otherwise maybe valve stem guides worn.
carnut1 is offline  
post #3 of 3 (permalink) Old 05-07-2007, 07:35 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Oct 2006
Vehicle: 1973 MB 280
Location: Oakville, Canada
Posts: 23
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Please read my update
kardar is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Key problem - Expert level problem analysis required philthompson W123 E,CE,D,CD,TD,TE Class 2 09-26-2006 08:48 AM
    1994 S600 coupe "Vacuum assist pump problem and now a starting problem Bigpauly52 W140 S-Class 18 09-26-2004 01:36 AM
    WTF ?? problem after problem....red fluid leaking !!!!!!!!!!!! jay (new jersey) R170 SLK-Class 7 11-03-2003 07:57 AM
    Interesting new problem, or is it a problem? My car's water broke yesterday Jason Y R170 SLK-Class 8 06-13-2001 07:54 PM
    Update on my cold start studdering problem - problem fixed? Douglas-Indianapolis R170 SLK-Class 4 04-25-2001 05:28 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome